Page MenuHomePhabricator

Link is missing from the 'Create the page ...' text on the search result page
Closed, InvalidPublic

Description

Author: steve

Description:
I'm searching for a keyword, e.g.: 'test' (the page does not exist yet). On the search result page the link is missing from the 'Create the page "Test" on this wiki!' text. Because of this issue I can't create new pages from my mobile.

Smartphone details: Sony Xperia SP, Android v4.3, Chrome v34


Version: unspecified
Severity: normal
OS: other
Platform: Smartphone

Details

Reference
bz65640

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 3:14 AM
bzimport set Reference to bz65640.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.May 22 2014, 3:40 PM

steve wrote:

Screenshot of the page where the issue can be found.

Attached:

steve wrote:

Hi Florian,

Yes, that page. I've attached a screenshot.

Since this speed up change:
https://gerrit.wikimedia.org/r/#/c/126723/1

First workaround for you: Change into Beta mode (Menu -> Settings -> Beta) and login, then redlinks are clickable. But in actual version of mobilefrontend (i looked into git repository), the "Create new page" is unvisible :?

I will add the change owner and reviewer to this bug (hope it's ok :)), so we can decide if we change here something or not. Because, like i said, the "Create the page" element isn't shown in actual git version and on Wikipedia Wikis.

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/fZd8diDV

steve wrote:

Thank you for the workaround. Unfortunately it's not working.

If "Create the page" element isn't shown then how can I add new pages?

Yeah, like i said, i thought you have a local installation, where you edit MobileFrontend to show these line :) To create a page for now, open the wiki with the pagename, for example:
http://en.m.wikipedia.org/wiki/Testsite_that_does_not_exist
and click the edit pen, like you want to edit an existing page.

jgonera wrote:

The screenshot you attached shows a pretty old version of MobileFrontend. On English Wikipedia it looks like this:
http://en.m.wikipedia.org/w/index.php?search=asgasggas&fulltext=search

No link, no plain text either.

Now the question is: Is the reason to hide the "create link" link via css still present? The change:
https://gerrit.wikimedia.org/r/#/c/76270/

I tested on local wiki, and the element is shown correctly?

If you look closely at the search page HTML the link is there it is just hidden via CSS with display none- it can be overriden by MediaWiki:Mobile.css though which is what I suspect Istvan Bujdoso is doing?
(see less/specials/search.less)

This sounds like a request for new page editing for a 3rd party wiki.
We should probably enable red links by default and configure it for Wikimedia wikis to be disabled. It seems to punish 3rd party users by not giving them the chance.

@Jon: Maybe a new configuration variable?

$wgMFNewPageCreation = false;
maybe.
At least than 3rd parties can toggle it on :)

Hmm, you would to toggle the create page link? Then the users have the problem, that the redlinks.js remove all links on page, including the "Create new". Maybe it's better to toggle the redlink remove, which remove the "Create page" link, if enabled :)
Maybe:
$wgMFRedlinkRemove
-> true: all redlinks will be removed (like actually) and serach create new page will be removed
-> false: nothing to do

Change 135120 had a related patch set uploaded by Florianschmidtwelzow:
Introducing new "wgMFRemoveRedlinks" config

https://gerrit.wikimedia.org/r/135120

steve wrote:

(In reply to Florian from comment #8)

Yeah, like i said, i thought you have a local installation, where you edit
MobileFrontend to show these line :) To create a page for now, open the wiki
with the pagename, for example:
http://en.m.wikipedia.org/wiki/Testsite_that_does_not_exist
and click the edit pen, like you want to edit an existing page.

Thanks for the workaround. Not exactly user friendly solution...

steve wrote:

(In reply to Jon from comment #11)

If you look closely at the search page HTML the link is there it is just
hidden via CSS with display none- it can be overriden by
MediaWiki:Mobile.css though which is what I suspect Istvan Bujdoso is doing?
(see less/specials/search.less)
This sounds like a request for new page editing for a 3rd party wiki.
We should probably enable red links by default and configure it for
Wikimedia wikis to be disabled. It seems to punish 3rd party users by not
giving them the chance.

Apart from the LocalSettings.php file I didn't edit any files. I only installed MediaWiki + MobileFrontend and didn't develop/modify anything on these systems.

steve wrote:

Does anyone know when will be a user friendly way to add new pages available to MobileFrontend? (E.g.: red links or a button)

Like Max Sem said in gerrit:

We have plans to deprecate red link removal completely, we'd better go down that road.

So, after the removal of redlinks is removed, the "create new page" link can be shown. I don't know, when the relink remove function will be deprecated :)

steve wrote:

Thank you for your reply Florian.

Could you tell me what is the name of the redlink remove function?

steve wrote:

Thank you.

I use the stable version of MediaWiki (v1.22.6) and the MobileFrontend that can be downloaded from https://www.mediawiki.org/wiki/Special:ExtensionDistributor/MobileFrontend.

I couldn't find any redlink related function in the MobileFrontend version I use.
Any suggestion how I could sort it out?

You use the version of REL1_22 branch, yes? Then, for now, i can not say, why the redlinks will be removed. The redlink remove function was implemented in April 2014 (in currently form):
https://gerrit.wikimedia.org/r/#/c/126723/

steve wrote:

Yes. I use the version of REL1_22 branch.

Something changes the link to span.
At the end of the link() function (core MediaWiki function, /includes/Linker.php) it is still a link:
<a href="/mediawiki/index.php?title=Test&amp;action=edit&amp;redlink=1" class="new" title="Test (page does not exist)">Test</a>

But the output in the browser is a span:
<span title="Test (page does not exist)" class="new">Test</span>

But the output in the browser is a span:

This is exactly that, what this function has to do ;)

Look at this change:
https://gerrit.wikimedia.org/r/#/c/83592/

So, i think, the redlinks removal will be in htmlformatter or mobileformatter, sorry, but i can't show atm :/

steve wrote:

I've found it. The doFlattenRedLinks() function in the MobileFormatter.php.

Thank you for your help.

This applies to an older version of MobileFrontend so marking as invalid.

I suggest opening a new bug for a configuration to make it easier for 3rd party users to have red links enabled by default as you're likely to run into this issue again in future when/if you upgrade.

Change 135120 merged by jenkins-bot:
Add "wgMFShowRedLinks" and "wgMFShowRedLinksAnon" config

https://gerrit.wikimedia.org/r/135120