Page MenuHomePhabricator

When Special:WhatLinksHere is included and a valid title not provided, a form is shown
Closed, ResolvedPublic

Description

To reproduce, navigate to the following URL:

https://en.wikipedia.org/w/index.php?title=User:PleaseStand/Sandbox&oldid=610241510

Under the heading {{Special:WhatLinksHere}}, a form is shown. I would expect to see either an error message or nothing instead.


Version: 1.24rc
Severity: trivial
URL: https://en.wikipedia.org/w/index.php?title=User:PleaseStand/Sandbox&oldid=610241510

Details

Reference
bz65779

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 3:24 AM
bzimport set Reference to bz65779.
bzimport added a subscriber: Unknown Object (MLST).

This doesn't seem like a bug to me. Any other behavior would be less useful.

(In reply to Jackmcbarn from comment #1)

This doesn't seem like a bug to me. Any other behavior would be less useful.

When transcluding {{Special:WhatLinksHere}}, you think it's appropriate to display an input form? I don't think this is expected behavior. I agree with Kevin that an error message or outputting nothing would be more expected here. The current behavior as described in comment 0 actually feels like a regression.

(In reply to MZMcBride from comment #2)

(In reply to Jackmcbarn from comment #1)

This doesn't seem like a bug to me. Any other behavior would be less useful.

When transcluding {{Special:WhatLinksHere}}, you think it's appropriate to
display an input form? I don't think this is expected behavior. I agree with
Kevin that an error message or outputting nothing would be more expected
here. The current behavior as described in comment 0 actually feels like a
regression.

With the form, {{Special:WhatLinksHere}} is a somewhat useful construct. Without it, it wouldn't be useful in any way. It doesn't show up when it would just get in the way, only when there's no other output.

(In reply to Jackmcbarn from comment #3)

With the form, {{Special:WhatLinksHere}} is a somewhat useful construct.
Without it, it wouldn't be useful in any way. It doesn't show up when it
would just get in the way, only when there's no other output.

This is a fair point. Thanks for bringing this up.

I think I've been conflating {{Special:WhatLinksHere}} (no input), {{Special:WhatLinksHere/Invalid <title}}, and {{Special:WhatLinksHere/Page without links}}. Sorry about that.

Are people using the {{Special:WhatLinksHere}} construct to intentionally add an input form to a page? Was this behavior intended or accidental (we'll need to look at the commit history to try to figure this out, I imagine)?

I still lean toward the view that this behavior is a bit magical and unexpected, but perhaps that's not such a bad thing. :-)

In my opinion it's the right and best behavior. An error message doesn't help the user really much. With an input form, he can use the form, if he want, with another search request :)

(In reply to MZMcBride from comment #4)

I think I've been conflating {{Special:WhatLinksHere}} (no input),
{{Special:WhatLinksHere/Invalid <title}}, and {{Special:WhatLinksHere/Page
without links}}. Sorry about that.

I created [[testwiki:bug 65779]] to capture the various cases I could think of off-hand.

gerritbot added a subscriber: gerritbot.

Change 184935 had a related patch set uploaded (by Umherirrender):
Remove form when including empty Special:WhatLinksHere

https://gerrit.wikimedia.org/r/184935

Patch-For-Review

Change 184935 merged by jenkins-bot:
Remove form when including empty Special:WhatLinksHere

https://gerrit.wikimedia.org/r/184935

Umherirrender closed this task as Resolved.Apr 7 2015, 8:43 PM

Will be part of 1.26wmf1 - see https://www.mediawiki.org/wiki/MediaWiki_1.26/Roadmap for the time line