Page MenuHomePhabricator

[Bug] timeouts during selenium tests with beta
Closed, ResolvedPublic

Description

Selenium tests are currently failing randomly. Sometimes with the message that the wiki "is in read-only mode" [1] or because the wiki is not available [2].

This should be investigated and fixed or sent upstream.

[1] http://wdjenkins.wmflabs.org/ci/job/wikibase-build-browsertests-saucelabs/60/consoleFull
[2] http://wdjenkins.wmflabs.org/ci/job/wikibase-build-browsertests-saucelabs/58/consoleFull


Version: unspecified
Severity: major
Whiteboard: u=dev c=QA p=0

Details

Reference
bz66071

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:26 AM
bzimport set Reference to bz66071.
bzimport added a subscriber: Unknown Object (MLST).
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 13 2015, 4:14 PM
JanZerebecki renamed this task from Investigate timeouts during selenium tests on beta to [Bug] Investigate timeouts during selenium tests on beta.Sep 10 2015, 1:12 PM
JanZerebecki renamed this task from [Bug] Investigate timeouts during selenium tests on beta to [Bug] timeouts during selenium tests on beta.
JanZerebecki moved this task from incoming to needs discussion or investigation on the Wikidata board.
JanZerebecki renamed this task from [Bug] timeouts during selenium tests on beta to [Bug] timeouts during selenium tests with sourcelabs.Oct 21 2015, 1:27 PM
JanZerebecki renamed this task from [Bug] timeouts during selenium tests with sourcelabs to [Bug] timeouts during selenium tests with beta.
JanZerebecki closed this task as Resolved.
JanZerebecki claimed this task.
JanZerebecki added a subscriber: JanZerebecki.

All the failures I see are usually because of saucelabs problems. Beta itself being the cause seems not to happen anymore.