Page MenuHomePhabricator

Text Looks garbled when using Bengali
Closed, ResolvedPublic

Description

Author: rabimba

Description:
Garbled Text

When I select any localized edition of Wikipedia (for this case Bengali) this appears.

Steps to reproduce:

  1. Open up the application
  2. Select বাংলা as the language
  3. Click on নতুন নিবন্ধ তৈরী করুন

Version: Alpha
Severity: normal
OS: other
Platform: Smartphone

Attached:

Details

Reference
bz66125

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:12 AM
bzimport set Reference to bz66125.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Jun 4 2014, 4:01 PM

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/wbH7ZVoT

You mean the app, right? I push this to Wikipedia App (you're now in MobileFrontend, the web based mobile layout ;)).

Can you say, what App you use? Version, plattform (Android, iOS)?

Can you tell me what version of Android you are using?

rabimba wrote:

I am using this in Android 4.3.1.
cyanogenmod 1.2.0-hercules (4.3.1 JLS36I)

The app version is 2.0-alpha-2014-06-03

Hope this helps

rabimba wrote:

(In reply to Florian from comment #2)

You mean the app, right? I push this to Wikipedia App (you're now in
MobileFrontend, the web based mobile layout ;)).
Can you say, what App you use? Version, plattform (Android, iOS)?

I am using this in Android 4.3.1.
cyanogenmod 1.2.0-hercules (4.3.1 JLS36I)

The app version is 2.0-alpha-2014-06-03

Is this still an issue?

Can't reproduce on my devices...

Rabimba: Is this still an issue?

rabimba wrote:

24thOct

Attached:

rabimba wrote:

(In reply to Andre Klapper from comment #8)

Rabimba: Is this still an issue?

Yes. It most certainly is. Just re-tested it (attachment 16897).

Android 4.4.4
ParanoidAndroid 4.6

Wikipedia 2.0-beta-2014-10-20

Anshoe added a subscriber: Anshoe.EditedDec 14 2014, 8:27 AM

Hi rabimba , I didn't get the 3rd step ? I changed my language to Bengali . but where do I click নতুন নিবন্ধ তৈরী করুন ?

I am using an Android : Version 4.2.1 Jelly Bean
App Version : 2.0-r-2014-12-01

Sorry, but I can't reproduce the problem, in fact I can't find the site, being on Android 4.4.2, app version 2.0-r-2014-12-01
What I did (or tried to do) in extreme detail just so we are sure:

  1. Open up the drawer from the left
  2. Clicked on the "<Gear icon> More" button at the bottom of the drawer
  3. Clicked on "Wikipedia language" under general
  4. Searched for Bengali and clicked on it
  5. Went back and searched for "নতুন নিবন্ধ তৈরী করুন" (I even copied and pasted it from this site)
  6. Got the message "No results found" :-(
Pmlineditor added a subscriber: Pmlineditor.EditedApr 6 2015, 10:19 AM

Tried it using Android 4.3 and got the same result as bug reporter. Looks like নতুন নিবন্ধ তৈরী করুন links to this page in the Bengali Wikipedia where the {{pullbox}} and {{wikipedia article creation}} are getting merged.

Regrettably I'm having a really hard time deciphering this bug because I can't speak Bengali. This makes it really hard for us to figure out how to fix the problem.

The original report was nice, but it didn't actually explain what the expected outcome was. Can someone please provide the following for this report?

  1. Steps to reproduce.
  2. Expected behaviour. A picture would be nice.
  3. Actual behaviour. A picture would be nice.

Can someone please re-test with the most recent production app, and confirm that this is still an issue? (please include screenshots of what you see, and note your OS version)

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 11 2015, 7:13 PM
Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptDec 10 2015, 11:03 PM

The problem no longer exists. I tested on a smartphone running Android 5.0.2 in the Wikipedia app (version: 2.1.136-r-2015-12-09). The steps that i followed:

  1. Downloaded and opened the Wikipedia app on Android.
  2. In the app, i swiped to the right to get to the menu and then clicked "Settings".
  3. Clicked on "Wikipedia language" and chose "Bengali".
  4. Went on the main screen of the app and searched for "উইকিপিডিয়া:নতুন নিবন্ধ শুরুকরণ".

Everything looks fine.

IoannisKydonis set Security to None.
Dbrant closed this task as Resolved.Dec 16 2015, 8:38 PM
Dbrant claimed this task.