Page MenuHomePhabricator

Add option to not add pages I revert to my watchlist
Closed, DuplicatePublic

Description

Currently, if I try monitor recent changes and rollback lots of vandalisms I end up filling my watchlist with pages I'm not really interested in watching (I just happened to notice inappropriate edits to them, so I reverted them). The only option available right now on
https://en.wikipedia.org/wiki/Special:Preferences#mw-prefsection-watchlist
is

  • Add pages and files I edit to my watchlist

But disabling this will not help me to keep watching articles where I'm really making contributions.


Version: 1.24rc
Severity: enhancement
See Also:
T7875: Group similar pages in watchlist (aka multiple watchlists)
T22444: Watchlist "Grouping"
T6488: Watch rollbacks

Details

Reference
bz66215

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 3:18 AM
bzimport added a project: MediaWiki-Watchlist.
bzimport set Reference to bz66215.
bzimport added a subscriber: Unknown Object (MLST).
He7d3r created this task.Jun 5 2014, 8:50 PM

By revert, do you mean the "undo" button? If about rollback, is this about adding a preference which does the contrary of T6488 (i.e. negate the preference for "edit")?

By revert, do you mean the "undo" button? If about rollback, is this about adding a preference which does the contrary of T6488 (i.e. negate the preference for "edit")?

Since the bug was reported on 2014-06-05, before gerrit change 146440 was deployed (with 1.24wmf16 on 14 August 2014), I think I was referring to the rollback feature, and this was a duplicate of T6488: Watch rollbacks (since I can just uncheck the option to watch rollbacks and I won't see the flood mentioned on T6488#87413 anymore).

(Or maybe this preference was not working with Huggle [which I was using that day] and my request was about it? Anyway, it is working on Huggle 3.1.8, so I'll close this)

He7d3r updated the task description. (Show Details)Jan 19 2015, 2:02 PM
He7d3r set Security to None.
He7d3r closed this task as a duplicate of T6488: Watch rollbacks.