Page MenuHomePhabricator

VisualEditor: Would be nice if copying/pasting kept working after a fatal
Closed, ResolvedPublic8 Story Points

Description

Obviously it'd also be nice if fatals didn't happen, but I have less faith that that is possible in shorter time…


Version: unspecified
Severity: enhancement

Details

Reference
bz66229
Related Gerrit Patches:
VisualEditor/VisualEditor : masterDon't break the editor if paste handling fails

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:19 AM
bzimport set Reference to bz66229.
  • Bug 64009 has been marked as a duplicate of this bug. ***

Need an example so I know where to put the try/catch.

Mostly seems to be caused by elements it doesn't recognise (? like <section>), especially when copying bits of tables and other structures from non-MediaWiki sources (e.g. Google Docs, Bugzilla or other places). Lots of different mystical errors as well about e.g. refusing to insert a closing tag that hasn't been opened.

Jdforrester-WMF edited a custom field.

Change 200649 had a related patch set uploaded (by Catrope):
Don't break the editor if paste handling fails

https://gerrit.wikimedia.org/r/200649

Change 200649 merged by jenkins-bot:
Don't break the editor if paste handling fails

https://gerrit.wikimedia.org/r/200649

Jdforrester-WMF closed this task as Resolved.Mar 30 2015, 11:11 PM
Jdforrester-WMF moved this task from Accepted to Done on the VisualEditor 2014/15 Q3 blockers board.
Jdforrester-WMF moved this task from Blocked to Q4 on the VisualEditor board.Mar 31 2015, 1:56 AM
gpaumier moved this task from To Triage to Announce in next Tech/News on the User-notice board.
gpaumier moved this task from Backlog to Triaged on the Notice board.
matej_suchanek moved this task from Triaged to Archive on the Notice board.Apr 7 2015, 3:07 PM