Page MenuHomePhabricator

Default image alignment is not applied to parsoid-output figure elements
Closed, ResolvedPublic

Description

If the alignment of an image is not explicitly set, Parsoid does not output an alignment class for the resultant figure element. This can lead to the image not being aligned/floated.

We need to modify content.parsoid.less to apply the default right-alignment styling to all images and then override this in cases where the alignment is explicitly set.


Version: 1.24rc
Severity: normal

Details

Reference
bz66282

Event Timeline

bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz66282.
bzimport added a subscriber: Unknown Object (MLST).
kaldari created this task.Jun 6 2014, 9:16 PM

Change 138038 had a related patch set uploaded by Kaldari:
Make sure images that don't have an explicit alignment get aligned right

https://gerrit.wikimedia.org/r/138038

Change 138106 had a related patch set uploaded by Kaldari:
Make sure images are properly aligned in Mobile VisualEditor

https://gerrit.wikimedia.org/r/138106

Change 138106 merged by jenkins-bot:
Make sure images are properly aligned in Mobile VisualEditor

https://gerrit.wikimedia.org/r/138106

  • Bug 66668 has been marked as a duplicate of this bug. ***

Right now this is deployed to group 1 wikis, but not yet to group 2. Lets keep this open until it has made its way there.

Also see tracking bug 51245 for more Parsoid-specifc CSS tweaking.

(In reply to Gabriel Wicke from comment #5)

Right now this is deployed to group 1 wikis, but not yet to group 2. Lets
keep this open until it has made its way there.

gwicke: So can this ticket be closed as FIXED?

Jdlrobson set Security to None.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 3 2015, 12:40 AM
Jdlrobson closed this task as Resolved.Nov 3 2015, 12:40 AM
Jdlrobson claimed this task.
Jdlrobson added a subscriber: Jdlrobson.

Seems like it must be fixed to me as of @Aklapper comment. @GWicke correct me if wrong.

Catrope removed a subscriber: Catrope.Nov 13 2015, 7:43 PM