Page MenuHomePhabricator

VisualEditor: In WebKit, moving the cursor (caret) with the arrow keys breaks connected Arabic letters
Closed, ResolvedPublic

Description

To reproduce:

  1. Edit an article in Arabic.
  2. Move the caret forward using the arrow keys.

Observed: The Arabic letters next to which the caret moves are disconnected.

Expected: Moving the caret must only move the caret. It must not change the appearance of the text.

This works well in Firefox, but broken in Chrome.


Version: unspecified
Severity: normal

Details

Reference
bz66339

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:09 AM
bzimport set Reference to bz66339.
Amire80 created this task.Jun 8 2014, 7:53 AM

I am not sure what fixed it, but it works for me now in Chrome 36.0.1985.143 on Fedora 20.

Can this be tested automatically to prevent regression?

Be sure to also test in a recent version of Safari (which runs on WebKit).

Chrome hasn't been based on WebKit for almost 2 years now. It's using Chromium/Blink instead.

Well, I reported it, and I only have Chrome on Linux, so I guess I meant "Chrome" or "Blink" and not "WebKit".

(In reply to Amir E. Aharoni from comment #3)

Well, I reported it, and I only have Chrome on Linux, so I guess I meant
"Chrome" or "Blink" and not "WebKit".

If it was present in Chrome at that point in time though, depending on whether it was a recent regression in Chrome, it likely still exists in WebKit/Safari (since Blink is a fork of WebKit).

Jdforrester-WMF lowered the priority of this task from High to Normal.Jan 9 2015, 10:55 PM
Amire80 closed this task as Resolved.Jan 10 2015, 8:27 AM
Amire80 claimed this task.

I cannot reproduce it in recent versions of Safari, Chrome and Firefox.