Page MenuHomePhabricator

Echo: Inconsistent link/bold formatting in flyout
Open, LowestPublic

Description

screenshot

Take a look at the attached screenshot and try to guess which words are actually links.

The correct answer is 'Eroc' and 'Mirza Mahdi Elahi Qomshehei', but I'll bet you $10 that's not what you guessed.

Personally, I think 'Eroc', 'DragonflySixtyseven', 'Qomsheh', and 'Mirza Mahdi Elahi Qomshehei' should all be bolded and linked.

Alternatively, we should only bold the words that are actually links. Otherwise, the bolding seems to be random.


Attached:

Details

Reference
bz66385

Related Objects

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:12 AM
bzimport set Reference to bz66385.
bzimport added a subscriber: Unknown Object (MLST).
kaldari created this task.Jun 9 2014, 5:50 PM
EBernhardson triaged this task as Lowest priority.Dec 11 2014, 3:11 AM
EBernhardson set Security to None.
Legoktm moved this task from Backlog to Needs code on the Notifications board.Jul 6 2015, 8:23 AM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJul 6 2015, 8:23 AM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptMay 27 2016, 4:34 PM
Krinkle removed a subscriber: Krinkle.Jun 2 2016, 8:01 PM
TerraCodes added a comment.EditedFri, Feb 14, 1:07 AM

I can reproduce this too (sometimes the username is bolded, but sometimes it isn't, looks like the page link is always bold tho)

Re-checked the notifications types that were described in the task, i.e.

  • a page was reviewed
  • a page was linked

There were some updates on wording in notifications (and overall design)

  • a page was reviewed - the title of the reviewed page is bold; the link to a user name is on a separate line - clicking anywhere on the notifications redirects to to the reviewed page
  • a page was linked - both pages titles are bold, clicking on the notification redirects to the page from where the link was made (from the screenshot it is Mavetuna703).

I can reproduce this too (sometimes the username is bolded, but sometimes it isn't, looks like the page link is always bold tho)

The inconsistency is, indeed is here:

  • the notification of successful mention - "Your mention of [user] was sent" - the username is bolded, but the redirect will be to the page where the mention was made

The following case of bolding seems to be fine:

  • the mention notification will bold a talk page title and a section title where the mention occurs