Page MenuHomePhabricator

ApiFlickrBlacklistTest::testBlacklistMatchByNsid fails
Closed, ResolvedPublic

Description

  1. ApiFlickrBlacklistTest::testBlacklistMatchByNsid

blacklist does not match
Failed asserting that two strings are equal.

  • Expected

+++ Actual
@@ @@
-'bad'
+'ok'

/srv/mediawiki/extensions/UploadWizard/tests/phpunit/ApiFlickrBlacklistTest.php:186
/srv/mediawiki/extensions/UploadWizard/tests/phpunit/ApiFlickrBlacklistTest.php:52
/srv/mediawiki/tests/phpunit/MediaWikiTestCase.php:133
/srv/mediawiki/tests/phpunit/MediaWikiPHPUnitCommand.php:42


Version: master
Severity: normal

Details

Reference
bz66938

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:29 AM
bzimport added a project: UploadWizard.
bzimport set Reference to bz66938.
bzimport added a subscriber: Unknown Object (MLST).
ori created this task.Jun 22 2014, 5:04 AM
ori added a comment.Jun 23 2014, 8:36 PM

It's actually three tests that are failing:

PHPUnit 4.1.3 by Sebastian Bergmann.

Configuration read from /srv/mediawiki/tests/phpunit/suite.xml

FFF.................................................

Time: 38.4 seconds, Memory: 20.72Mb

There were 3 failures:

  1. ApiFlickrBlacklistTest::testBlacklistMatchByNsid

blacklist does not match
Failed asserting that two strings are equal.

  • Expected

+++ Actual
@@ @@
-'bad'
+'ok'

/srv/mediawiki/extensions/UploadWizard/tests/phpunit/ApiFlickrBlacklistTest.php:186
/srv/mediawiki/extensions/UploadWizard/tests/phpunit/ApiFlickrBlacklistTest.php:52
/srv/mediawiki/tests/phpunit/MediaWikiTestCase.php:133
/srv/mediawiki/tests/phpunit/MediaWikiPHPUnitCommand.php:42

  1. ApiFlickrBlacklistTest::testBlacklistMatchByUsername

blacklist does not match
Failed asserting that two strings are equal.

  • Expected

+++ Actual
@@ @@
-'bad'
+'ok'

/srv/mediawiki/extensions/UploadWizard/tests/phpunit/ApiFlickrBlacklistTest.php:186
/srv/mediawiki/extensions/UploadWizard/tests/phpunit/ApiFlickrBlacklistTest.php:70
/srv/mediawiki/tests/phpunit/MediaWikiTestCase.php:133
/srv/mediawiki/tests/phpunit/MediaWikiPHPUnitCommand.php:42

  1. ApiFlickrBlacklistTest::testBlacklistMatchWithMultipleItems

blacklist does not match
Failed asserting that two strings are equal.

  • Expected

+++ Actual
@@ @@
-'bad'
+'ok'

/srv/mediawiki/extensions/UploadWizard/tests/phpunit/ApiFlickrBlacklistTest.php:186
/srv/mediawiki/extensions/UploadWizard/tests/phpunit/ApiFlickrBlacklistTest.php:82
/srv/mediawiki/tests/phpunit/MediaWikiTestCase.php:133
/srv/mediawiki/tests/phpunit/MediaWikiPHPUnitCommand.php:42

FAILURES!
Tests: 52, Assertions: 70, Failures: 3.

This appears to be caused by not having network access to the tests (Apparently it treats unable to read flickr api response as image is ok...)

Change 141582 had a related patch set uploaded by Brian Wolff:
Make unit tests be skipped if no network.

https://gerrit.wikimedia.org/r/141582

Change 141582 merged by jenkins-bot:
Make unit tests be skipped if no network.

https://gerrit.wikimedia.org/r/141582

All patches mentioned in this report were merged - is there more work left to do here (if yes: please reset the bug report status to NEW or ASSIGNED), or can you close this ticket as RESOLVED FIXED?

This looks fixed to me.

Gilles moved this task from Untriaged to Done on the Multimedia board.Dec 2 2014, 8:54 AM