Page MenuHomePhabricator

Include redirects in RDF rendering.
Closed, ResolvedPublic1 Story Points

Description

The RDF representation of an entity should include all redirects to the entity, represented using owl:sameas in RDF.


Version: unspecified
Severity: enhancement
Whiteboard: u=dev c=backend p=0

Details

Reference
bz67033
Related Gerrit Patches:

Related Objects

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 3:36 AM
bzimport set Reference to bz67033.
bzimport added a subscriber: Unknown Object (MLST).
daniel created this task.Jun 24 2014, 4:10 PM
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).

Even tougher question would be what happens if there's a redirect on property. Is this even possible? owl:sameAs may not even accept properties as parameters, at least in some meanings of OWL. And as for support in inference, no idea at all.

See also T96590, which asks for redirect info to be included the the JSON rendering of entities.

Even tougher question would be what happens if there's a redirect on property. Is this even possible?

Wikibase currently does not allow properties to be redirected or merged, but we have not committed to a guarantee that we will never allow this.

owl:sameAs may not even accept properties as parameters, at least in some meanings of OWL. And as for support in inference, no idea at all.

Wikibase properties are not OWL properties, and should never be used as if they were. So I see no problem there.

As to support for inference... I would have expected triple stores / SPARQL engines to cater to basic needs like this. Seems like we are further away from a functioning semantic web than I thought...

Blazegraph has a step where IRI can be converted to internal representation, and we could plug in there and implement aliasing that way (see also T96490). That probably would work for properties too, but of course it's not portable. I'm ok with the fact that we don't allow it now and we'll cross that bridge when we come to it.

The cases we're looking for in RDF, assuming Q6 is a redirect to Q4:

  1. If the output is for /wiki/Special:EntityData/Q6.rdf?flavor=dump, there should be Q6 owl:sameAs Q4. Data on Q4 is optional.
  2. If the output is for /wiki/Special:EntityData/Q6.rdf?flavor=somethingelse, there should be Q6 owl:sameAs Q4 present in the data, and the data on Q4.
  3. For dump, there should be data for Q4 and the data for Q6 should be included as Q6 owl:sameAs Q4. No other data about Q6 (i.e. not duplicate of Q4 data) should be present.

Change 208660 had a related patch set uploaded (by Daniel Kinzler):
Include redirect info in output from Special:EntityData

https://gerrit.wikimedia.org/r/208660

Change 208667 had a related patch set uploaded (by Daniel Kinzler):
Omit meta-info if flavor=dump is used on Special:EntityData

https://gerrit.wikimedia.org/r/208667

Change 208660 merged by jenkins-bot:
Include redirect info in output from Special:EntityData

https://gerrit.wikimedia.org/r/208660

Change 208667 merged by jenkins-bot:
Omit meta-info if flavor=dump is used on Special:EntityData

https://gerrit.wikimedia.org/r/208667

daniel added a comment.May 4 2015, 7:33 PM
NOTE: above patches only include info about redirects that were followed to the data. Including info about ALL redirects is still pending. Perhaps we should split the ticket.

Change 209012 had a related patch set uploaded (by Daniel Kinzler):
Include incoming redirects in RDF output of Special:EntityData

https://gerrit.wikimedia.org/r/209012

Change 209012 had a related patch set uploaded (by Daniel Kinzler):
Include incoming redirects in RDF output of Special:EntityData

https://gerrit.wikimedia.org/r/209012

Change 209012 merged by jenkins-bot:
Include incoming redirects in RDF output of Special:EntityData

https://gerrit.wikimedia.org/r/209012

daniel closed this task as Resolved.May 6 2015, 4:48 PM
daniel moved this task from Review to Done on the Wikidata-Sprint-2015-05-05 board.
Tobi_WMDE_SW edited a custom field.May 25 2015, 11:12 AM