Page MenuHomePhabricator

Search suggestions do not work for cross-namespace redirects
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. visit hu.wikipedia.org
  2. type "WP:T" in the search box

Expected: [[hu:WP:T]] (a redirect to [[hu:Wikipédia:Törlésre javasolt lapok]]) is suggested

Actual: no suggestions appear

The AJAX request sent by the search box handler is
https://hu.wikipedia.org/w/api.php?action=opensearch&format=json&search=WP%3AT&namespace=0&suggest=

The response is
["WP:T",[]]


Version: unspecified
Severity: normal

Details

Reference
bz67520

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:33 AM
bzimport added a project: CirrusSearch.
bzimport set Reference to bz67520.
bzimport added a subscriber: Unknown Object (MLST).
Tgr created this task.Jul 4 2014, 5:19 AM

It seems to be working correctly now.

Restricted Application added a project: Discovery. · View Herald TranscriptJul 26 2015, 2:17 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Deskana closed this task as Resolved.Jul 27 2015, 5:35 PM
Deskana claimed this task.

I'm going to assume this is fixed then. Please do ping me if there are issues.

Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptDec 31 2015, 5:10 AM
Restricted Application added a project: Discovery-Search. · View Herald TranscriptJul 17 2016, 2:21 AM