Page MenuHomePhabricator

PageTriage: test SpecialNewPagesFeedTest::testAddArticles has 'Unknown error: "wminc-error-unprefixed"'
Closed, DeclinedPublic

Description

Spotted while running phpunit tests with most of the extensions from the WMF branch.

$ cd tests/phpunit
$ php phpunit --testsuite extensions
...
SpecialNewPagesFeedTest::testAddArticles
Failed asserting that two strings are equal.

  • Expected

+++ Actual
@@ @@
-'The article you tried to create has been created already'
+'Unknown error: "wminc-error-unprefixed"'

extensions/PageTriage/tests/phpunit/SpecialNewPagesFeedTest.php:103
tests/phpunit/MediaWikiTestCase.php:133
tests/phpunit/MediaWikiPHPUnitCommand.php:42
tests/phpunit/phpunit.php:160

https://integration.wikimedia.org/ci/job/mediawiki-core-extensions-integration/67/testReport/junit/(root)/SpecialNewPagesFeedTest/testAddArticles/

I could not reproduce locally needs to be investigated :-/


Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=67608

Details

Reference
bz67615

Event Timeline

bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz67615.
bzimport added a subscriber: Unknown Object (MLST).
hashar created this task.Jul 7 2014, 6:40 PM

Can't repro, though https://gerrit.wikimedia.org/r/#/c/147350/ fixes an unrelated test failure.

Eh, the message is from WikimediaIncubator, will try tomorrow.

hashar added a comment.Aug 6 2014, 1:30 PM

This is still occurring:

SpecialNewPagesFeedTest::testAddArticles
Failed asserting that two strings are equal.

  • Expected

+++ Actual
@@ @@
-'The article you tried to create has been created already'
+'Unknown error: "wminc-error-unprefixed"'

/srv/ssd/jenkins-slave/workspace/mediawiki-core-extensions-integration/src/extensions/PageTriage/tests/phpunit/SpecialNewPagesFeedTest.php:103
/srv/ssd/jenkins-slave/workspace/mediawiki-core-extensions-integration/src/tests/phpunit/MediaWikiTestCase.php:133
/srv/ssd/jenkins-slave/workspace/mediawiki-core-extensions-integration/src/tests/phpunit/phpunit.php:233

The Gerrit patch https://gerrit.wikimedia.org/r/147545 ArticleMetadataTest.php.

hashar added a comment.Aug 6 2014, 1:53 PM

I am no more using WikimediaIncubator since it conflicts with PageTriages tests as well as EducationProgram tests (bug 67608).

Moving bug under WikimediaIncubator.

Ebe123 added a subscriber: Ebe123.Nov 24 2014, 9:03 PM
Paladox set Security to None.May 1 2015, 6:46 PM
Hydriz added a subscriber: Hydriz.Sep 5 2015, 2:57 PM

@hashar I don't think this bug can be fixed on our end. Preventing unprefixed pages is part of the design of the extension, and it is likely that the PageTriages extension is trying to create a page that is not within a prefix (such as "Wp/en" like in the Incubator).

I reckon declining this task.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 5 2015, 2:57 PM
Hydriz closed this task as Declined.Apr 8 2017, 1:54 PM

Declined per my comment 2 years ago.