Page MenuHomePhabricator

Change default thumbnail size to 300px for all WMF wikis
Open, Stalled, LowPublic

Description

T69703: Change MediaWiki default thumbnail size to 300px based on user behavior suggests that we change the default wiki thumbnail size to 300px width, based on user settings data, for all Wikimedia wikis as well as for the MediaWiki software itself. Copying here for that part of the change.

Details

Reference
bz67709

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 3:28 AM
bzimport set Reference to bz67709.
bzimport added a subscriber: Unknown Object (MLST).
TTO added a comment.Jul 9 2014, 2:13 AM
  • This bug has been marked as a duplicate of bug 49357 ***

Change 154408 had a related patch set uploaded by Jforrester:
Increase default thumbnail display size from 220px to 300px

https://gerrit.wikimedia.org/r/154408

I've scheduled this for the SF-morning SWAT slot on Monday, 25 August.

Has this been announced to the wider community ?

DJ, via village technical pump and ambassadors list

TheDJ added a comment.Aug 21 2014, 3:44 PM

Actually, I checked the news update and the deploy of the change seem to be scheduled for the same day.

https://meta.wikimedia.org/wiki/Tech/News/2014/35

Seems that that is a bit short notice...

(In reply to Derk-Jan Hartman from comment #6)

Actually, I checked the news update and the deploy of the change seem to be
scheduled for the same day.
https://meta.wikimedia.org/wiki/Tech/News/2014/35
Seems that that is a bit short notice...

That's the reminder update I put in that it's happening – there was an initial annoucement back in June, I thought?

I don't see reference to any sort of user studies indicating this change would be positive (or at least non-detrimental) for readers, even those not browsing with fullscreen browsers on large displays or mobile devices with extreme display densities. Nor do I see any evidence that the community at large was informed about this, much less asked for input.

The one discussion I did find, https://en.wikipedia.org/wiki/Wikipedia:Village_pump_%28technical%29/Archive_128#Time_for_the_semi-annual_enlarging_of_thumbnail_images, was closed as "no consensus". Mainly because it was mostly people giving opinion with no actual user research.

So yeah, let's not go making such user-visible changes without some support for why we're doing them.

(In reply to Jared Zimmerman (WMF) from comment #5)

DJ, via village technical pump and ambassadors list

The Thumbnail Style update, was announced on the ambassadors list (and then postponed), but not the Thumbnail Size change.

I don't feel comfortable with pushing this change, especially right now. There is enough of a mess already, I don't want us to generate more.

I propose we just have this sit around until someone comes asking again, and then we point them here, saying there is no technical reasons not to do it, only political and that if they show us something that resembles a community agreement _across_ the wiki's, we will deploy this. That will save us the time in having to shepherd this through, collect evidence and deal with post change effects. Lets use that time for more important and constructive long term improvements, like for instance... SUL

I mean, it's not like we need this from a software or operations point of view. Design wants it (but I don't see how it would be critical to them) and a lot of community members have asked for it, but until someone shows me something resembling community consensus over multiple wikis, i'm not very much inclined to support a change like this. And even when that is there, we still need to do a substantial announcement.

So for anyone visiting this ticket: "Please show that you have the support of a substantial number of wikimedia communities and NO, for technical reasons, this is NOT a per project decision."

Restricted Application added subscribers: Matanya, Aklapper. · View Herald TranscriptAug 12 2015, 12:36 AM
Luke081515 closed this task as Declined.Feb 2 2016, 12:22 AM

Declined per T124354. There is no consensus for this change yet. Please reopen the task if consensus reached.

Restricted Application added a subscriber: JEumerus. · View Herald TranscriptFeb 2 2016, 12:22 AM
Luke081515 reopened this task as Open.Feb 2 2016, 12:45 AM
Jdlrobson changed the task status from Open to Stalled.Apr 19 2017, 6:42 PM
Jdlrobson moved this task from Incoming to Product Owner Backlog on the Readers-Web-Backlog board.
Jdlrobson added subscribers: ovasileva, Jdlrobson.

Not sure on what but looks like it stalled. @ovasileva could you talk about the issues here with @Jdforrester-WMF ?

phuedx removed a subscriber: phuedx.Jun 5 2017, 11:02 AM