Page MenuHomePhabricator

UploadWizard fails to show error if in multiple uploads, an individualized license is left blank
Closed, ResolvedPublic

Description

Author: neilk

Description:
To replicate:

  • Upload two or more photos.
  • At the licensing step, ask to provide details for each item individually.
  • Leave at least one item unlicensed (i.e. don't click anything in the license area)
  • Press "Next"
  • The button does not take you to the next step, but also does not show any errors. Nothing happens.

Version: unspecified
Severity: normal

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:35 AM
bzimport added a project: UploadWizard.
bzimport set Reference to bz68082.
bzimport added a subscriber: Unknown Object (MLST).

neilk wrote:

However, the upload itself isn't stalled - the user can fix the problem and then proceed. Presumably the issue is that the validator cannot deal with a completely blank UploadWizardDeed any more. Also, probably the default license should be applied to the multiple deeds.

Which browser do you use?

neilk wrote:

(In reply to Steinsplitter from comment #2)

Which browser do you use?

I'm seeing it in Chrome 35 and Firefox 30.

Gilles triaged this task as Medium priority.Nov 24 2014, 2:35 PM
Gilles added a subscriber: Gilles.
Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 6:35 PM
Restricted Application added subscribers: Matanya, Aklapper. · View Herald TranscriptSep 4 2015, 6:35 PM
matmarex claimed this task.Nov 2 2015, 1:36 PM

Change 249893 had a related patch set uploaded (by Bartosz Dziewoński):
mw.UploadWizardDeed: Do not assume that deed is always set

https://gerrit.wikimedia.org/r/249893

Change 249893 merged by jenkins-bot:
mw.UploadWizardDeed: Do not assume that deed is always set

https://gerrit.wikimedia.org/r/249893

matmarex closed this task as Resolved.Nov 3 2015, 8:54 PM