Page MenuHomePhabricator

Add 'more' button at end of watch list feed, to look further in history
Closed, DuplicatePublic

Description

Currently the items in the watch list are limited to a certain amount. If you get to the end, you are done. For more experienced users with bigger watch lists, the initial view often covers just minutes or an hour.

Not really sufficient. This is aggravated by the behavior due to bug 68367


Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=68367
https://bugzilla.wikimedia.org/show_bug.cgi?id=68369

Details

Reference
bz68368

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 3:37 AM
bzimport set Reference to bz68368.
bzimport added a subscriber: Unknown Object (MLST).
TheDJ created this task.Jul 22 2014, 9:57 AM

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/YSgWl1rm

How can I reproduce it? I have 57 items on my watchlist, and all of them show up. How many items should I add before some of them don't show up?

MMM..
According to code 50 should be enough.
const LIMIT = 50; // Performance-safe value with PageImages

Try dropping that to 1 or 2 and see what happens

Remember, that, if you click the "Watchlist" link in left navigation, you normally ends up in Special:EditWatchlist, which uses SpecialEditWatchlist's getWatchlistInfo(), which has no limit. If you want to see the mobile related code, click to "modified" to go to Special:Watchlist, which is (in mobile view) implemented in SpecialMobileWatchlist, which has a (working) limit of 50 rows :)

Baha said: @jonrobson1 How should the "more" button look? Which of the .ui-mw- class should I use?

May.... According to http://tools.wmflabs.org/styleguide/desktop/section-2.html it could either be neutral or progressive (since it takes you to more results). What do you think?

I think progressive.

(In reply to Jon from comment #5)

May.... According to
http://tools.wmflabs.org/styleguide/desktop/section-2.html it could either
be neutral or progressive (since it takes you to more results). What do you
think?

I think neutral is better as progressive, it's not really a workflow where a next step can be reached :)

*** Bug 71961 has been marked as a duplicate of this bug. ***

Restricted Application added a project: Readers-Web-Backlog. · View Herald TranscriptApr 8 2015, 7:17 AM

(To facilitate discussion while on desktop, the mobile watchlist currently looks like this. I understand it's hardcoded to 50 entries.)

Agree that this would be great to have. This is one of the issues that currently severely reduce the mobile web interface's usefulness for curation activities. As an editor who often does this kind of work work and has accumulated a rather large watchlist, I check it like once a day or once every few days, and try to check changes back to the time of my last visit. But right now, the mobile watchlist on enwiki only goes back 1 hour and 6 minutes for me. On desktop, I can view changes from the last 30 days if I want to.

I talked about this a while ago with @JKatzWMF (and before that with other members of the Mobile Web team), and there was a sense that infinite scrolling might be an elegant solution - but a "more" button or some "Show last x hours / y days" like on desktop would solve the issue too.

Patches greatly welcomed here. We want this it's just a case of not having time.

Jdlrobson renamed this task from Add 'more' button at end of watch list, to look further in history to Add 'more' button at end of watch list feed, to look further in history.Jun 4 2015, 10:19 PM
Jdlrobson set Security to None.
Jhernandez closed this task as Resolved.Aug 17 2015, 12:07 PM
Jhernandez claimed this task.
Jhernandez added a subscriber: Jhernandez.

There's infinite scrolling on the mobile watchlist now, so this shouldn't be a problem. When getting to the end of the list it should automatically load the next page of results.

Jdlrobson reopened this task as Open.Aug 17 2015, 3:02 PM

This is referring to the traditional feed view (edits)

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 17 2015, 3:02 PM
Jhernandez raised the priority of this task from Low to Medium.Aug 17 2015, 5:37 PM

Woops, sorry, very reasonable then.

MaxSem removed a subscriber: MaxSem.Aug 17 2015, 6:34 PM
Jdlrobson lowered the priority of this task from Medium to Low.Jul 21 2016, 8:45 PM
Jdlrobson moved this task from Incoming to Triaged but Future on the Readers-Web-Backlog board.