Page MenuHomePhabricator

"You need to attribute the author" is wrong in case of CC0/Public Domain files
Closed, ResolvedPublic

Description

Test case: see URL.

The image is released under CC0 by the photographer. The text "You need to attribute the author" shown by the MultimediaViewer is wrong. No attribution is legally needed.

I suggest to show an alternative message in case of CC0/Public Domain files. Something like "No attribution needed. Cite suggestion:"


Version: unspecified
Severity: normal
URL: https://de.wikipedia.org/wiki/Helikontuba?uselang=en#mediaviewer/Datei:Helikontuba_von_Michael_von_Muecke.jpg

Details

Reference
bz68687
Related Gerrit Patches:
mediawiki/extensions/CommonsMetadata : masterAdd a flag to force local recalculation of the metadata
mediawiki/extensions/MultimediaViewer : masterText changes for better handling of PD and nonfree licenses
mediawiki/extensions/CommonsMetadata : masterAdditional license properties: AttributionRequired, NonFree

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 3:41 AM
bzimport added a project: MediaViewer.
bzimport set Reference to bz68687.
bzimport added a subscriber: Unknown Object (MLST).
Raymond created this task.Jul 27 2014, 6:23 PM
Tgr added a comment.Jul 28 2014, 5:13 AM

Pretty sure we had a bug about this already but I am unable to find it.

[[commons:COM:MRD]]-style licenses have an licensetpl_attr_req field already, we just need to expose it in CommonsMetadata and use it in MediaViewer.

Ever since the MediaViewer was released, I've been inundated with people asking me about the attribution requirements for my photos. The entire reason I release all my photos as CC0 is because I don't want to be attributed and I don't want to spend all day answering emails from people who want to use my photos. I would suggest changing the wording to just "No attribution needed."

Let's get this fixed; as far as I can tell this is already information that exists at the level of the license metadata but is not currently returned by the metadata API (licensetpl_attr_req).

Thanks, Raymond. Good catch. :)

For now, I created this card on our Mingle planning site, to track this request:

  • #1004 Don't require attribution for Public Domain or CC0 files

https://wikimedia.mingle.thoughtworks.com/projects/multimedia/cards/1004

I’ve proposed copy for the attribution change, and Cc:d both Pau and Luis, so we’re all on the same page.

Gilles and the multimedia engineering team will determine when to take on this request, but it’s on our radar now as part of our current development cycle.

Much appreciated.

Tgr added a comment.Nov 18 2014, 6:42 PM
  • Bug 71611 has been marked as a duplicate of this bug. ***

Change 175502 had a related patch set uploaded (by Gerg? Tisza):
Additional license properties: AttributionRequired, NonFree

https://gerrit.wikimedia.org/r/175502

Patch-For-Review

Change 175573 had a related patch set uploaded (by Gerg? Tisza):
Text changes for better handling of PD and nonfree licenses

https://gerrit.wikimedia.org/r/175573

Patch-For-Review

Change 175502 merged by jenkins-bot:
Additional license properties: AttributionRequired, NonFree

https://gerrit.wikimedia.org/r/175502

Change 175573 merged by jenkins-bot:
Text changes for better handling of PD and nonfree licenses

https://gerrit.wikimedia.org/r/175573

Gilles added a comment.Dec 1 2014, 5:07 PM

Is there an easy way to test those changes that combine a CommonsMetadata and Media Viewer update on beta? It seems like CommonsMetadata will always pull the information from Commons proper.

Tgr added a comment.Dec 1 2014, 5:58 PM

Is there an easy way to test those changes that combine a CommonsMetadata and Media Viewer update on beta? It seems like CommonsMetadata will always pull the information from Commons proper.

There is a version number at the top of HookHandler; CMD data with a matching version from the remote gets reused, but if the local version number differs, it will be discarded and recalculated locally. (You need to clear the cache, on a vagrant box that's redis-cli FLUSHDB.)

Gilles added a comment.Dec 2 2014, 9:29 AM

So is the answer that these combined changes are currently untestable on beta?

Tgr added a comment.Dec 2 2014, 5:36 PM

Sorry, I missed the "on beta" part. They are untestable on beta with Commons files (unless we bump the CommonsMetadata API version, or add a configuration setting to always override remote data, which could be done). You need to upload something to beta Commons if you want to test CommonsMetadata changes.

Change 177016 had a related patch set uploaded (by Gergő Tisza):
Add a flag to force local recalculation of the metadata

https://gerrit.wikimedia.org/r/177016

Patch-For-Review

Gilles added a comment.Dec 3 2014, 1:37 PM
In T70687#801990, @Tgr wrote:

You need to upload something to beta Commons if you want to test CommonsMetadata changes.

Could you do that, then? It's much easier when I review tasks for acceptance before our weekly meeting if there's somewhere the feature can be used easily. It also makes it demoable for the meeting itself.

Change 177016 merged by jenkins-bot:
Add a flag to force local recalculation of the metadata

https://gerrit.wikimedia.org/r/177016

Tgr added a comment.Dec 3 2014, 4:38 PM

Could you do that, then? It's much easier when I review tasks for acceptance before our weekly meeting if there's somewhere the feature can be used easily. It also makes it demoable for the meeting itself.

http://en.wikipedia.beta.wmflabs.org/wiki/File:Enwiki-survey-relative.png

Tgr closed this task as Resolved.Dec 5 2014, 7:44 PM
Tgr claimed this task.
Gilles moved this task from Untriaged to Done on the Multimedia board.Dec 8 2014, 1:17 PM