Page MenuHomePhabricator

[ErrorHandler] PHP Notice: Undefined index: en in extensions/ErrorHandler/ErrorHandler.php on line 223
Closed, ResolvedPublic

Description

PHP Notice: Undefined index: en in /srv/vagrant/mediawiki/extensions/ErrorHandler/ErrorHandler.php on line 223
PHP Stack trace:

PHP   1. {main}() /srv/vagrant/mediawiki/maintenance/update.php:0
PHP   2. require_once() /srv/vagrant/mediawiki/maintenance/update.php:206
PHP   3. require() /srv/vagrant/mediawiki/maintenance/doMaintenance.php:81
PHP   4. include_once() /srv/vagrant/mediawiki/LocalSettings.php:126
PHP   5. include_once() /srv/vagrant/LocalSettings.php:113
PHP   6. include_once() /srv/vagrant/settings.d/40-OtherExtensions.php:413
PHP   7. efErrorHandler() /srv/vagrant/settings.d/40-OtherExtensions.php:46
PHP   8. efErrorGetText() /srv/vagrant/mediawiki/extensions/ErrorHandler/ErrorHandler.php:183
PHP   9. call_user_func_array() /srv/vagrant/mediawiki/extensions/ErrorHandler/ErrorHandler.php:250
PHP  10. efErrorHandlerGetMessage() /srv/vagrant/mediawiki/extensions/ErrorHandler/ErrorHandler.php:250

Version: master
Severity: normal

Details

Reference
bz68701
Related Gerrit Patches:
mediawiki/extensions/ErrorHandler : masterRead messages from JSON file

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 22 2014, 3:42 AM
bzimport set Reference to bz68701.
bzimport added a subscriber: Unknown Object (MLST).
Nemo_bis created this task.Jul 28 2014, 1:11 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 8 2015, 10:41 AM
Liuxinyu970226 added a subscriber: IAlex.
Victorbarbu updated the task description. (Show Details)Jan 15 2016, 6:58 PM
Victorbarbu updated the task description. (Show Details)

Probably the problem is that the code assumes the .i18n.php file exists *and* defines an array containing all the messages, while we switched to JSON. https://www.mediawiki.org/wiki/Localisation_file_format

Change 266070 had a related patch set uploaded (by PranavK):
Fix Undefined Index error

https://gerrit.wikimedia.org/r/266070

Pranavmk98 added a subscriber: Pranavmk98.

I have uploaded the necessary patch above ^

Reedy closed this task as Resolved.Dec 21 2016, 10:51 AM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptDec 21 2016, 10:51 AM

Change 266070 merged by jenkins-bot:
Read messages from JSON file

https://gerrit.wikimedia.org/r/266070