Page MenuHomePhabricator

Please add the deleted domain *.eur.nl again to the wgCopyUploadsDomains whitelist
Closed, DeclinedPublic

Description

Please add again the following deleted domain to the wgCopyUploadsDomains whitelist:

*.eur.nl

for uploads such as

http://www.eur.nl/fileadmin/ASSETS/ihs/Wikipedia_Slides/Slides-cat87-Bombay-etc-1979-PB/PICT0002.JPG

Explanation

I am a Dutch Wikipedian in special residence, presently at the IHS (Institute for Housing and Urban Development Studies, Erasmus University, Rotterdam, http://www.eur.nl/). One of my tasks is to upload hundreds of images to Wikimedia Commons - https://en.wikipedia.org/wiki/Wikipedia:GLAM/Wikipedians_in_Special_Residence_in_the_Netherlands_2013-2014.

The GlamWikiToolset requires a whitelisted URL as the source for images to upload to Wikimedia Commons. *.eur.nl was whitelisted before (bug 67355). https://bugzilla.wikimedia.org/show_bug.cgi?id=67355 . Due to copyright problems with the uploadables - now solved - i could not upload from *.eur.nl domain in the last weeks. Perhaps this prompted the deletion of *.eur.nl from the whitelist?

However, now *.eur.nl is missing from the white list on http://gwtoolset.wmflabs.org/wiki/Special:GWToolset.

Error message

Attempts to upload test files are met with the following error message:

"There was a problem processing the metadata file.
Copy uploads are not available from this domain."

Thank you for considering this request,
Kind regards,

Hans Muller (https://commons.wikimedia.org/wiki/User:Hansmuller)


Version: wmf-deployment
Severity: enhancement

Details

Reference
bz68803

Event Timeline

bzimport raised the priority of this task from to Needs Triage.
bzimport set Reference to bz68803.
bzimport added a subscriber: Unknown Object (MLST).

I now find out that fortunately i CAN upload on the GWToolSet production site
https://commons.wikimedia.org/wiki/Special:GWToolset
where the domain *.eur.nl is whitelisted allright!

But i can NOT upload to the GWToolSet test site
http://gwtoolset.wmflabs.org/wiki/Special:GWToolset.

So the whitelisting would be appreciated for this test site.
Kind regards,

Hans Muller (https://commons.wikimedia.org/wiki/User:Hansmuller)
~~~~

Don't know the exact details why this was reverted.
CC'ing the GWToolset maintainers / default CCs, maybe somebody knows.

(In reply to Andre Klapper from comment #2)

Don't know the exact details why this was reverted.
CC'ing the GWToolset maintainers / default CCs, maybe somebody knows.

Its currently enabled on production (originally bug 67355). It has not been reverted.

It should also work fine on commons beta http://deployment.wikimedia.beta.wmflabs.org/wiki/Main_Page . I believe the gwtoolset beta wiki (gwtoolset.wmflabs.org) is an old test wiki for gwtoolset that isn't used anymore (dan-nl can confirm whether that is correct). For now I reccomend doing all testing on http://commons.wikimedia.beta.wmflabs.org/wiki/Commons:GLAMToolset_project

dan-nl added a comment.Aug 3 2014, 9:53 PM

the situation is as bawolff mentioned above.

hans, please use the commons beta server to test any uploads.