Page MenuHomePhabricator

Wizard refuses to upload images from flickr via http
Closed, InvalidPublic

Description

Author: cometstyles

Description:
When trying to upload an image from flickr to commons via [[Special UploadWizard/Flickr]] using http, when we add the image link to the "Get from Flickr", it goes to the next step but the image just keeps on loading (in a loop).... it doesn't go any further ..only affects http version, not the https one..

The web console for the browser shows this:

GET https://api.flickr.com/services/rest/ [HTTP/1.1 200 OK 3453ms]
GET https://api.flickr.com/services/rest/ [HTTP/1.1 200 OK 1282ms]
GET http://commons.wikimedia.org/w/api.php [HTTP/1.1 200 OK 2064ms]
GET https://api.flickr.com/services/rest/ [HTTP/1.1 200 OK 547ms]
GET http://commons.wikimedia.org/w/api.php [HTTP/1.1 200 OK 985ms]
POST http://commons.wikimedia.org/w/api.php [HTTP/1.1 504 Gateway Time-out 10433ms]


Version: unspecified
Severity: normal
OS: Windows Vista
Platform: PC

Details

Reference
bz68981

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:26 AM
bzimport added a project: UploadWizard.
bzimport set Reference to bz68981.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Aug 1 2014, 1:01 AM
Tgr added a comment.Aug 1 2014, 1:16 AM

At a glance, this seems like an upload error which is not related to Flickr. Can you reproduce with the same file? Can you reproduce with a file from a different Flickr user?

cometstyles wrote:

it worked with a different flickr user

GET https://api.flickr.com/services/rest/ [HTTP/1.1 200 OK 3597ms]
GET https://api.flickr.com/services/rest/ [HTTP/1.1 200 OK 1142ms]
GET https://api.flickr.com/services/rest/ [HTTP/1.1 200 OK 1175ms]
POST http://commons.wikimedia.org/w/api.php [HTTP/1.1 200 OK 11281ms]
GET http://commons.wikimedia.org/w/api.php [HTTP/1.1 200 OK 817ms]

^^
GET http://commons.wikimedia.org/wiki/Special:UploadStash/thumb/12h8xso51xgc.l7uzmb.1129056.jpg/100px-12h8xso51xgc.l7uzmb.1129056.jpg [HTTP/1.1 200 OK 2064ms]

Tgr added a comment.Aug 1 2014, 2:04 AM

And with the original user it fails all the time?
Maybe the user is blacklisted and the error message about the blacklist is not returned for some reason? The blacklist is at https://commons.wikimedia.org/wiki/User:FlickreviewR/bad-authors

cometstyles wrote:

tried it with multiple others, seems to be be affecting one user who releases all his images under (cc-by-sa) and no he is not blacklisted, probably one of the only few to release their images fully on flickr..

did the same test on test.wikipedia.org using http, same outcome

GET https://api.flickr.com/services/rest/ [HTTP/1.1 200 OK 1471ms]
GET https://api.flickr.com/services/rest/ [HTTP/1.1 200 OK 905ms]
GET https://api.flickr.com/services/rest/ [HTTP/1.1 200 OK 557ms]
POST http://commons.wikimedia.org/w/api.php [HTTP/1.1 504 Gateway Time-out 11060ms]

^
Request URL: http://commons.wikimedia.org/w/api.php
Request Method: POST
Status Code: HTTP/1.1 504 Gateway Time-out

It works for me https://commons.wikimedia.org/wiki/File:Kitten_with_laptop_-_278017185.jpg.

Can you pls clear your browser cache and try again?

cometstyles wrote:

Its still a problem, when on http (http://commons.wikimedia.org/wiki/Special:UploadWizard), it refuses to upload most images, it goes on a loop, nothing to do with vrowser cache, more to do with being unable to converts https API link to http ..
web console data for "POST" (http://pastebin.com/HfbLGEXm)

Gilles triaged this task as Normal priority.Nov 24 2014, 2:29 PM
Gilles added a subscriber: Gilles.
Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 6:35 PM
Restricted Application added subscribers: Matanya, Aklapper. · View Herald TranscriptSep 4 2015, 6:35 PM
jayvdb closed this task as Invalid.Oct 8 2015, 9:38 AM
jayvdb claimed this task.
jayvdb added a subscriber: jayvdb.

Using http urls works for me.
To make this bug report reproducible, please indicate which image is not working.