Page MenuHomePhabricator

Special:BlockList displays 500 items instead of default 50
Closed, ResolvedPublic

Description

The default number of items per page on Special:BlockList is 50, but when first opened, it will display 500.


Version: 1.24rc
Severity: minor

Details

Reference
bz69132

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 3:36 AM
bzimport set Reference to bz69132.
bzimport added a subscriber: Unknown Object (MLST).

Hmm, can't reproduce in local test environment with 1.24 master and not on mediawiki.org: https://www.mediawiki.org/wiki/Special:BlockList

Have you an example wiki or a special configuration or something else?

This comment was removed by RobinHood70.

Actually, I just figured it out. It's the Recent Changes setting that controls it. In earlier versions (confirmed up to 1.22), the preferences menu text makes it appear that that only controls Recent Changes when, in fact, it appears to control several things, including logs, as seen in the more modern preferences menu.

Since this is the case, I would say that the bug is actually that the default number of items displayed in the dropbox should be made to match that number. For example, if I set my Recent Changes items to 500 in my Preferences, then go to Special:BlockList, the "Items per page" still defaults to 50. Either that should be fixed or log entries should be separated out from the number of Recent Changes preference.

Florian claimed this task.May 27 2015, 5:39 AM

@RobinHood70: Thanks for reporting this. You're right, the default value should be the same as the one used to display the rows.

Change 213981 had a related patch set uploaded (by Florianschmidtwelzow):
Show correct default limit in Special:BlockList

https://gerrit.wikimedia.org/r/213981

Umherirrender closed this task as Resolved.Jul 26 2015, 6:36 PM
Umherirrender set Security to None.

Change 213981 merged by jenkins-bot:
Show correct default limit in Special:BlockList

https://gerrit.wikimedia.org/r/213981