Page MenuHomePhabricator

Disable reuse suggestion when no license and/or attribution is known
Closed, ResolvedPublic

Description

When the MediaViewer has no license information discourage reuse in the "Use this file" popin by explaining that it needs more research and referring to the files page for possibly more information. Otherwise it would encourage use of files without properly following their license.


Version: unspecified
Severity: major
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=69534

Details

Reference
bz69557

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:30 AM
bzimport set Reference to bz69557.
bzimport added a subscriber: Unknown Object (MLST).
Tgr added a comment.Aug 14 2014, 8:26 PM

CC Pau for design thoughts. Jan, do you have any specific phrasing in mind?

Replacing the content of the reuse popin with "Please investigate the license and/or attribution before reusing this image. The file page (add link) might have more information." should do the trick. But I don't have any specific UI or phrasing requirements in mind, as long as it doesn't encourage reuse without checking first.

Missing attribution information should be handled similarly.

I don't think the severity is enhancement because this is a regression compared to the file page that does not encourage reuse without license or attribution.

Just noting that there is no particular discouragement or difference in the level of encouragement of reuse on Commons for media from unknown/unidentified authors: https://commons.wikimedia.org/wiki/Category:Unidentified_authors , https://commons.wikimedia.org/wiki/Category:Whipped_Peter

The images in these categories have all the same links and opportunities for downloading and/or usage as any other media. Suggest that before this change is made, there be a discussion at Commons on whether or not this enhancement/change is desired.

Lupo added a comment.Aug 18 2014, 9:48 AM

(In reply to Risker from comment #3)

Just noting that there is no particular discouragement or difference in the
level of encouragement of reuse on Commons for media from
unknown/unidentified authors:
https://commons.wikimedia.org/wiki/Category:Unidentified_authors ,
https://commons.wikimedia.org/wiki/Category:Whipped_Peter
The images in these categories have all the same links and opportunities for
downloading and/or usage as any other media. Suggest that before this change
is made, there be a discussion at Commons on whether or not this
enhancement/change is desired.

No red tape needed. It's not very complicated. Do not encourage re-use outside of WMF projects (do not provide embeddable HTML etc.) if:

  • MediaViewer cannot find any license info, or
  • MediaViewer finds a license that requires attribution, but cannot find an attribution/author
  • MediaViewer detects that the license might be incorrect (that'd be bug 69389)

In the first two cases, the proposed re-use HTML will result in an invalid re-use. And in the third case, it'll encourage re-use of wrongly licensed images. (Typical case: copyvio uploaded as "own work" and cc-by-sa-3.0, then detected and put up for deletion.) Both are bad.

Note that the second bullet would nicely handle the "Unidentified authors" cases you mention, if those images are properly licensed. (They should actually all have a PD license tag, and PD licenses do not require attribution, so it'd be OK for MediaViewer to produce re-use HTML without author info.)

This bug is only about MediaViewer suggesting reuse, it woun't change anything on the File pages on Commons (which per default do not encourage or suggest reuse).

Reason for the severity is that the function lost here is "not encouraging copyright violations".

Gilles triaged this task as Normal priority.Nov 24 2014, 1:57 PM
Gilles added a subscriber: Gilles.
Tgr set Security to None.

Not really a regression as MediaViewer never did this.

It is compared to the file page. It is also compared to MediaViewer not suggesting reuse. This bug has wider implications than just making the suggestion feature less useful. Before the reuse suggestion was deployed this was not done, hence this fits the definition of regression. Yes new features can contain regressions. Why do you think they can't?

Tgr added a comment.Dec 5 2014, 9:50 PM

Per the wiki page linked from the label description,

A software regression is a software bug which makes a feature stop functioning as intended after a certain event (for example, a system upgrade, system patching or a change to daylight saving time).

A new feature that does not function the same way an old feature does is not a regression, even if it should function the same way. (And even if that comparison is not completely arbitrary :) Just assuming that the file page stops reuse because it dumps a mountain of information on the user, and some tiny part of that information mentions e.g. that the author is missing, seems like wishful thinking to me.) Regressions are things that can be caught by regression testing, can be prevented by unit tests, etc. None of that applies here.

Fabrice_Florin renamed this task from when no license and/or attribution is known disable reuse suggestion to Disable reuse suggestion when no license and/or attribution is known.Dec 6 2014, 3:27 AM
Fabrice_Florin added a subscriber: LuisV_WMF.

Thanks for bringing this up, @JanZerebecki !

Turns out this issue happens frequently enough to justify making this fix in this release, according to Gergo’s latest metrics: author information is missing from 15% of images viewed with Media Viewer. And sources are missing 14% of the time, licenses 6% of the time.

So I recommend the team consider adding this to the current cycle, since Gergo thinks it's easy.

Here are ideas for possible alternative wordings in the Download panel:

  • ‘You need to attribute the source’ (if there is a source, but no author)
  • You need to include license info’ (if there is a license, but no author or source)
  • Don’t show any attribution prompts in the Download panel (if there is no author, source or license)

In that last case where there is no license, I tend to agree with @bzimport's suggestion to not provide embeddable HTML in the Embed panel either, if it's easy to do.

BTW, here's a sample file without an author, if we want to look at these wordings based on a concrete example: https://en.wikipedia.org/wiki/File:%22Blackout%22_(1950).jpg#mediaviewer/File:%22Blackout%22_(1950).jpg

Sorry, I meant to cite lupo.bugzilla in my last comment, not bzimport. My bad. Still learning the ins and outs of Phabricator ... :(

Tgr added a comment.Dec 6 2014, 4:08 AM

I would rather handle this, T76030 and T71389 in the same way - show a warning, and show a best effort attribution text in all the panels (our attribution text generator code already handles missing author/source/license). The reuser might not care about legal status, in which case it's better if they at least attribute. (They might even have a legitimate reason for not caring - e.g. if you are preparing teaching materials in an EU country, you are pretty much exempt from copyright.)

If we go that way, the groundwork needed for this, T76030 and T71389 is pretty much the same, so I can do them in one swoop, or they can be finished by a Google Code-In student.

Good idea, Gergo! I think it makes very good sense to use a more generic warning, so we can get this work done in a timely and practical manner, as part of this cycle. You have my support to go ahead with this.

Change 178059 had a related patch set uploaded (by Gergő Tisza):
Add functions to display/remove a warning in the dialogs

https://gerrit.wikimedia.org/r/178059

Patch-For-Review

Change 178141 had a related patch set uploaded (by Gergő Tisza):
Display warnings for licence/attribution problems

https://gerrit.wikimedia.org/r/178141

Patch-For-Review

Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 6:34 PM
Restricted Application added subscribers: Matanya, Aklapper. · View Herald TranscriptSep 4 2015, 6:34 PM

Mass-removing the Multimedia tag from MediaViewer tasks, as this is now being worked on by the Reading department, not Editing's Multimedia team.

Patch is currently -1ed.

Jdlrobson changed the task status from Open to Stalled.Jan 20 2016, 8:00 PM

Work on this seems to have stalled. Please change status to open when you have a time to address the feedback and want our attention for code review.

@Jdlrobson ye olde Multimedia team is gone, @Tgr has other priorities and responsibilities, and Reading has taken over MMV (in theory) - I would suggest one of them reviving the old patch or writing a new one...

Nemo_bis changed the task status from Stalled to Open.Jan 23 2016, 12:00 PM
Nemo_bis added a subscriber: Nemo_bis.

This is not stalled. The requirements at T71557#722087 are very clear and were not -1'ed. The current patch seems to do more than requested, probably a simpler patch should be made.

Sure. The reading team also has other priorities and responsibilities but a patchset remains open, so maybe that should be abandoned to allow someone else to feel open to working on this? Whilst a patchset is open @Tgr retains responsiblity. I'm happy to get this prioritised alongside other stuff but I need a clear signal whether @Tgr plans to do it.

The last comment from @Tgr was on Sep 28th way after his departure from the MMV team which said "I'll fix it sometime this week."
@Tgr can you clarify the situation?

Stalled obviously has different meanings depending on who you ask...
Macro whereismypopcorn:

Tgr added a comment.Jan 29 2016, 12:30 AM

The last comment from @Tgr was on Sep 28th way after his departure from the MMV team which said "I'll fix it sometime this week."

Uh. I tend to do that :/

Definitely won't have time for this before the end of the AuthManager project. If you are in a hurry, feel free to rewrite/discard/whatever.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptApr 27 2016, 4:19 PM
MarkTraceur moved this task from Backlog to Next on the MediaViewer board.Apr 25 2017, 6:31 PM

This can probably be worked on pretty soon.

matthiasmullie moved this task from Next to In Process on the MediaViewer board.

Change 178059 merged by jenkins-bot:
[mediawiki/extensions/MultimediaViewer@master] Add functions to display/remove a warning in the dialogs

https://gerrit.wikimedia.org/r/178059

Change 178141 merged by jenkins-bot:
[mediawiki/extensions/MultimediaViewer@master] Display warning for licence/attribution problems

https://gerrit.wikimedia.org/r/178141

matthiasmullie closed this task as Resolved.Sep 28 2017, 1:50 PM