Page MenuHomePhabricator

Deprecate redlink removal (enable redlinks in stable)
Closed, ResolvedPublic

Description

This bug should track the plans to deprecate the redlink removal sometimes in the future.

Extension talk: https://www.mediawiki.org/wiki/Thread:Extension_talk:MobileFrontend/Red_links

Related gerrit discussion (from https://gerrit.wikimedia.org/r/#/c/135120/):

MaxSem: We have plans to deprecate red link removal completely, we'd better go down that road.

Florianschmidtwelzow: @MaxSem: Ah, ok, that i don't know :) Then, it's better to don't merge this commit, so nobody get confused with a new config deprecate in next versions :)

MaxSem: I'd say wait a bit for redlinks promotion to stable, because the solution it this commit would be way too temporary:)


Version: unspecified
Severity: enhancement

Details

Reference
bz69849

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:32 AM
bzimport set Reference to bz69849.
bzimport added a subscriber: Unknown Object (MLST).
Florian created this task.Aug 21 2014, 12:26 PM

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/l7H9t4of

  • Bug 72467 has been marked as a duplicate of this bug. ***
Restricted Application added a project: Readers-Web-Backlog. · View Herald TranscriptApr 8 2015, 7:17 AM
Nemo_bis triaged this task as Normal priority.May 13 2015, 5:51 AM
Nemo_bis added a subscriber: Nemo_bis.

Change 212967 had a related patch set uploaded (by Florianschmidtwelzow):
Don't remove redlinks for experienced users

https://gerrit.wikimedia.org/r/212967

I've merged your patch Florian. I say that when we click the red link it opens up a Drawer which says:
"This page doesn't exist." <Create new article><Fix broken link><Ok>

Fix broken link can open up the edit screen for the current page using the section that the link belongs to.
Let's try this out in beta first with some click tracking and then push to stable and call this bug done.
cc @JKatzWMF

Change 212967 merged by jenkins-bot:
Show a CtaDrawer when the user clicks a red link

https://gerrit.wikimedia.org/r/212967

At the hackathon Jon Katz Florian and I found a way forward with this and I'm now happy to call this closed. We should monitor number of edits/reverts to ensure this doesn't have too much of a negative impact.

Jdlrobson closed this task as Resolved.May 29 2015, 7:52 PM
Jdlrobson claimed this task.

At the hackathon Jon Katz Florian and I found a way forward with this and I'm now happy to call this closed. We should monitor number of edits/reverts to ensure this doesn't have too much of a negative impact.

Danny_B renamed this task from [Tracking] Deprecate redlink removal (enable redlinks in stable) to Deprecate redlink removal (enable redlinks in stable).Aug 16 2016, 1:15 AM
Danny_B removed a project: Tracking-Neverending.
Danny_B removed a subscriber: wikibugs-l-list.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMar 7 2018, 1:22 AM