Page MenuHomePhabricator

404 errors after renaming specific files on Commons
Closed, ResolvedPublic

Description

In the process of renaming files to improve titles, four of them somehow became unviewable, in which the image doesn't display and when clicking the image a 404 error message appears stating "The resource could not be found". Seeking advice on how to fix these files. The files are:

File:Pizza (7).jpg
File:Chimichangas.jpg
File:Hamburger and fries - Hackney Picturehouse, Hackney, London.jpg
File:Hamburgers and fries at a restaurant in Brandon, Florida.jpg

– Northamerica1000 (talk) 21:28, 26 August 2014 (UTC)

See https://commons.wikimedia.org/wiki/Commons:Village_pump#404_errors


Version: wmf-deployment
Severity: normal

Details

Reference
bz70079

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 3:30 AM
bzimport set Reference to bz70079.
bzimport added a subscriber: Unknown Object (MLST).

Improper moves, it seems the images were still connected to the old name. Moving back and forth fixed it.
Any idea why they became out of sync?

(In reply to Denniss from comment #2)

Improper moves, it seems the images were still connected to the old name.
Moving back and forth fixed it.
Any idea why they became out of sync?

Swift backend was overloaded, there was a bug that if that happened, page would be moved, image would not be (see bug 69312)

  • This bug has been marked as a duplicate of bug 69311 ***
Gilles moved this task from Untriaged to Done on the Multimedia board.Dec 4 2014, 9:28 AM
Steinsplitter reopened this task as Open.Mar 18 2015, 9:49 AM
Steinsplitter set Security to None.

Reopening bug...

This was reported a while ago on two other bugs, but i can't find them with the phabricator searchfunction (maybe closed as dupe?).

Steinsplitter closed this task as Resolved.Mar 18 2015, 9:53 AM
Steinsplitter claimed this task.

Oh, it is T93009