Page MenuHomePhabricator

mediawiki.language should respect $wgTranslateNumerals in convertNumber()
Closed, ResolvedPublic

Description

In Arabic Wikipedia, in type="number" elements (see Main Page history for instance) and the 'N more languages' line of the Compact Language Links feature are displayed Eastern numerals (٠‎ ١‎ ٢‎) instead of conventional Western numerals (0 1 2).


See Also:
T64725: Use "ar-u-nu-latn" instead "ar" for whole Arabic Wikipedia or just for its <input type="number">

Details

Reference
bz70109

Event Timeline

bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz70109.
Zack created this task.Aug 27 2014, 9:55 PM

Thanks for taking the time to report this!

Confirming: On https://ar.wikipedia.org/w/index.php?title=الصفحة_الرئيسية&action=history this can be seen in the (من سنة (وأقدم field.

and the 'N more languages' line of the Compact Language Links

Might be a separate issue; not sure.

Also not sure which codebase this falls into; bug 62725 feels related.

My quick guess that it would in core, rather than in ULS.

It looks like the JavaScript implementation of number conversion ( mw.language.convertNumber() ) indeed doesn't check for $wgTranslateNumerals, so this affects not only ULS.

Niklas, Santhosh - you are more familiar with this JS code, am I correct or am I missing something?

gerritadmin wrote:

Change 164730 had a related patch set uploaded by Amire80:
Respect $wgTranslateNumerals in JavaScript

https://gerrit.wikimedia.org/r/164730

  • Bug 66383 has been marked as a duplicate of this bug. ***
Krinkle updated the task description. (Show Details)Jan 9 2015, 3:06 AM
Krinkle reassigned this task from Krinkle to Amire80.
Krinkle set Security to None.
Krinkle removed a subscriber: Krinkle.
Restricted Application added a project: UniversalLanguageSelector. · View Herald TranscriptMar 10 2015, 2:53 PM

Change 164730 had a related patch set uploaded (by Bartosz Dziewoński):
mediawiki.language: Respect $wgTranslateNumerals in convertNumber()

https://gerrit.wikimedia.org/r/164730

Change 212942 had a related patch set uploaded (by Siebrand):
mediawiki.language: Respect $wgTranslateNumerals in convertNumber()

https://gerrit.wikimedia.org/r/212942

Change 164730 merged by jenkins-bot:
mediawiki.language: Respect $wgTranslateNumerals in convertNumber()

https://gerrit.wikimedia.org/r/164730

Change 212942 merged by jenkins-bot:
mediawiki.language: Respect $wgTranslateNumerals in convertNumber()

https://gerrit.wikimedia.org/r/212942

demon closed this task as Resolved.May 23 2015, 3:20 PM
demon added a subscriber: demon.

Done in master and backported for REL1_25.

Amire80 moved this task from Backlog to Other on the ULS-CompactLinks board.Nov 3 2017, 8:27 AM