Page MenuHomePhabricator

Make the CAPTCHA more visible when saving
Closed, ResolvedPublic

Description

  1. Sign up with a new username to a Wikimedia site.
  2. Edit an article and add an external link.
  3. Try saving.

After entering an edit summary and pressing the button in the dialog, the dialog remains and the CAPTCHA is shown in its bottom. At least on my machine, I need to scroll down in the dialog to actually see the CAPTCHA. I saw new users puzzled over this - they thought that they already pressed the save button and couldn't understand why is the dialog still there.


Version: unspecified
Severity: normal

Details

Reference
bz70266

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:42 AM
bzimport set Reference to bz70266.
Amire80 created this task.Sep 1 2014, 6:34 PM
Jdforrester-WMF triaged this task as Normal priority.Feb 11 2015, 5:15 PM
jayvdb raised the priority of this task from Normal to High.Jun 20 2015, 2:28 AM
jayvdb added a subscriber: jayvdb.

If VE is going to be rolled out to new editors, surely this must be a high priority?
https://en.wikipedia.org/wiki/Wikipedia:Village_pump_%28proposals%29#Gradually_enabling_VisualEditor_for_new_accounts

I see closed tasks T52356 and T64766, but no other tasks relating to CAPTCHA, either open or closed. Is this well covered by test scenarios?

Elitre added a subscriber: Elitre.Jun 20 2015, 6:30 AM

I haven't been successful so far in finding a way to replicate (I tested several times in these months and couldn't replicate in IE, FF, Opera or Chrome. TBH, rather than creating a new account, I just use incognito window because I was testing a report from an IP user).
I'm inclined to think that this may have been fixed by some design changes, but if it's still occurring for any of you and you can please post details of how you manage to reproduce it, I'd be happy to mark it as a "blocker".

So the steps as an anon (should be the same?) are:

  1. Edit using VE as an anon http://enwp.org/User:Elitre/Sandbox?veaction=edit
  2. Add an EL http://blah.com/foo
  3. step through the save process

It should show
"Warning:
CAPTCHA: To edit this page, please enter the words that appear below in the box (more info):"

And image appears below it.

Ive tried in twice on Chrome and once on Firefox. Two times it worked; once when I tried it on Chrome (Fedora 20; 43.0.2357.81), the warning appeared and the image didnt.

The warning should not be shown until the image is shown, and if the image doesnt arrive, it should display an error message.

Also, it never shows the 'refresh' link to get another CAPTCHA, which is often necessary when the CAPTCHA is unreadable. I checked and the 'source editor' has that. Probably a separate bug.

The CAPTCHA is appearing in the visible area, for me. Only the previously visible licensing info (which needs to have been read before clicking "Save" anyway!) gets scrolled out of view:


So possibly this particular task needs to be retitled or refined?

I've confirmed there's no refresh. Filed as T103227: VisualEditor: CAPTCHA has no refresh button

Hey, thanks a lot for testing!

So the steps as an anon (should be the same?) are:

I assume so, since the captcha is triggered then as well.

  1. Edit using VE as an anon http://enwp.org/User:Elitre/Sandbox?veaction=edit
  2. Add an EL http://blah.com/foo
  3. step through the save process

It should show
"Warning:
CAPTCHA: To edit this page, please enter the words that appear below in the box (more info):"
And image appears below it.
Ive tried in twice on Chrome and once on Firefox. Two times it worked; once when I tried it on Chrome (Fedora 20; 43.0.2357.81), the warning appeared and the image didnt.
The warning should not be shown until the image is shown, and if the image doesnt arrive, it should display an error message.

I think this is a different issue then? (and maybe one with javascript?) Amir says that he needs to scroll down to see the captcha. In all my tests, the captcha is always immediately visible (as in Nick's second screenshot).
Which OS do you have? Mine is Win 7 (I'll test in my Macbook Air later).

Also, it never shows the 'refresh' link to get another CAPTCHA, which is often necessary when the CAPTCHA is unreadable. I checked and the 'source editor' has that. Probably a separate bug.

Try it on a smaller screen. A lot of people still use 1024×768 or even smaller screens.

How about putting it above the edit summary or instead of it?

Amire80 set Security to None.

Try it on a smaller screen. A lot of people still use 1024×768 or even smaller screens.

I get exactly the same result in an 800x600 window

How about putting it above the edit summary or instead of it?

My suggestion, would be to highlight the text-input-box, which is currently hard to detect underneath the CAPTCHA.
Not that the current wikitext version is much better...

Sidenote: There's also T54133: VisualEditor: Edit summary box should be a text input box and not textarea which if implemented will help reduce the size of that entire save window (and also fix T50274 - the missing autocomplete dropdown of previously used editsummaries (if someone let's their browser remember form-history. madness!))

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 21 2015, 6:48 PM
Jdforrester-WMF renamed this task from VisualEditor: CAPTCHA that appears when saving is hard to find to Make the CAPTCHA more visible when saving.Aug 18 2015, 7:16 PM
Jdforrester-WMF lowered the priority of this task from High to Low.
Jdforrester-WMF moved this task from To Triage to Freezer on the VisualEditor board.

So the steps as an anon (should be the same?) are:

  1. Edit using VE as an anon http://enwp.org/User:Elitre/Sandbox?veaction=edit
  2. Add an EL http://blah.com/foo
  3. step through the save process

I received a captcha when using the source editor but not with the visual editor.

VisualEditor doesn't have any magic way to bypass it, are you sure it saved successfully and that nothing else changed?

The order was switched in https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/VisualEditor/+/335223/ when adding a slide transition, putting the messages under the footer - we should switch them back.

Change 479197 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Move save error messages above save footer

https://gerrit.wikimedia.org/r/479197

BeforeAfter

Change 479197 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Move save error messages above save footer

https://gerrit.wikimedia.org/r/479197

marcella closed this task as Resolved.Jan 8 2019, 9:45 PM
marcella claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJan 8 2019, 9:45 PM
Ryasmeen reassigned this task from marcella to Esanders.Jan 8 2019, 10:39 PM
Ryasmeen added a subscriber: marcella.