Page MenuHomePhabricator

CirrusSearch: -"quoted phrase" doesn't remove the phrase from the search results
Closed, ResolvedPublic

Description

Looks like -"quoted phrase" doesn't remove the phrase from the search results. Link to source of bug: https://www.mediawiki.org/wiki/Topic:S1b3m6774w8qpf8t

Searching for <<"test" -"foo bar">> yields the following query_string query:
<<(all.plain:\"test\" \\-\"foo bar\"~0^1)>> when it really should be something like <<all.plain:\"test\" -all.plain:\"foo bar\">>


Version: unspecified
Severity: normal

Details

Reference
bz70301

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:42 AM
bzimport added a project: CirrusSearch.
bzimport set Reference to bz70301.
bzimport added a subscriber: Unknown Object (MLST).

gerritadmin wrote:

Change 157972 had a related patch set uploaded by Manybubbles:
Fix negated phrase search

https://gerrit.wikimedia.org/r/157972

gerritadmin wrote:

Change 157972 merged by jenkins-bot:
Fix negated phrase search

https://gerrit.wikimedia.org/r/157972

All patches mentioned in this report were merged - is there more work left to do here (if yes: please reset the bug report status to NEW or ASSIGNED), or can you close this ticket as RESOLVED FIXED?

demon removed a subscriber: demon.Aug 19 2015, 3:39 PM
Restricted Application added a project: Discovery. · View Herald TranscriptAug 19 2015, 3:39 PM
Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptDec 10 2015, 11:00 PM
Deskana closed this task as Resolved.Dec 31 2015, 3:58 AM
Deskana claimed this task.

A quick test indicates that this now works as intended.