Page MenuHomePhabricator

[Regression] WMFLabs: Unable to delete any instance
Closed, DuplicatePublic

Description

I'm no longer able to delete any instances.

  1. Go to https://wikitech.wikimedia.org/wiki/Nova_Resource:I-000004b5.eqiad.wmflabs
  2. Follow "delete" link

I'm now on https://wikitech.wikimedia.org/w/index.php?title=Special:NovaInstance&action=delete&project=integration&instanceid=c3eb4dc2-0a2b-4fec-9215-4ef1eeb34607&region=eqiad
which displays only:

<b>Notice</b>: Undefined variable: endpointURL in <b>/usr/local/apache/common-local/php-1.24wmf15/extensions/OpenStackManager/nova/OpenStackNovaController.php</b> on line <b>834

The actual confirmation form to delete the instance does not show, instead it says "The requested host does not exist." which is most definitely not true (I tried it with various other instances in different labs projects, all the same).


Version: unspecified
Severity: major

Details

Reference
bz70636

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:47 AM
bzimport set Reference to bz70636.
bzimport added a subscriber: Unknown Object (MLST).
Krinkle created this task.Sep 9 2014, 11:46 PM

I just retested and this worked fine for me. Can you log out and in again and recheck please?

Krinkle changed the task status from Declined to Resolved.Nov 24 2014, 10:08 PM
Krinkle claimed this task.

Yeah, it's worked fine since. It's one of the various side-effects of wikitech seemingly-randomly losing its auth connection with OpenStack and having to log out and in again.