Page MenuHomePhabricator

If Chrome browser zoom set to 90% or less, icon positions too high/low in toolbar
Closed, ResolvedPublic

Description

Screenshot of toolbar

See screenshot.
The yellow "mop"-icon is mw.loader.load("//de.wikipedia.org/w/index.php?title=Benutzer:TMg/autoFormatter.js&action=raw&ctype=text/javascript");
I tried disabling it, that didn't fix it.

I'm using:

Google Chrome OS

Version 37.0.2062.119 (64-bit)

Plattform 5978.81.0 (Official Build) stable-channel glimmer

Google_Glimmer.5216.198.4

WebKit - 537.36 (@1e1614b)

V8 - 3.27.34.15

Agent - Mozilla/5.0 (X11; CrOS x86_64 5978.81.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.119 Safari/537.36

Comandrow - /opt/google/chrome/chrome --ppapi-flash-path=/opt/google/chrome/pepper/libpepflashplayer.so --ppapi-flash-version=14.0.0.177-r1 --ppapi-flash-args=enable_hw_video_decode=1 --register-pepper-plugins=/opt/google/chrome/pepper/libnetflixhelper.so#NetflixHelper#Helper for the Netflix application#2.0.0;application/x-ppapi-netflixhelper --enable-fixed-position-compositing --enable-impl-side-painting --max-tiles-for-interest-area=512 --ui-enable-per-tile-painting --ui-prioritize-in-gpu-process --gpu-sandbox-failures-fatal=yes --enable-logging --log-level=1 --use-cras --user-data-dir=/home/chronos --max-unused-resource-memory-usage-percentage=5 --login-profile=user --has-chromeos-keyboard --ash-default-wallpaper-large=/usr/share/chromeos-assets/wallpaper/default_large.jpg --ash-default-wallpaper-small=/usr/share/chromeos-assets/wallpaper/default_small.jpg --ash-guest-wallpaper-large=/usr/share/chromeos-assets/wallpaper/guest_large.jpg --ash-guest-wallpaper-small=/usr/share/chromeos-assets/wallpaper/guest_small.jpg --device-management-url=https://m.google.com/devicemanagement/data/api --enterprise-enable-forced-re-enrollment --enterprise-enrollment-initial-modulus=11 --enterprise-enrollment-modulus-limit=15 --vmodule=screen_locker=1,webui_screen_locker=1,network_portal_detector_impl=1,reset_screen_handler=1,update_engine_client=1,*ui/display/chromeos*=1,*ash/display*=1,*zygote*=1,*plugin*=2 --login-manager --termination-message-file=/tmp/.org.chromium.Chromium.8fiql8/.org.chromium.Chromium.lTTEKi --first-exec-after-boot --silent-launch


Version: unspecified
Severity: normal
OS: other
Platform: PC
Whiteboard: 0.4.0 (rEWED9ed80e824321)

Attached:

Details

Reference
bz70679

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:50 AM
bzimport set Reference to bz70679.
bzimport added a subscriber: Unknown Object (MLST).
Josve05a created this task.Sep 10 2014, 7:37 PM

Where can this be seen? URL welcome :)

Whoops, I can reproduce with Google Chrome 37 on any page on English Wikipedia.

Thanks for the report.

This issue also appears to be mentioned on the (very confusingly titled) bug 35342, see bug 35342 comment 19 and later.

TheDJ closed this task as Resolved.Nov 30 2014, 7:50 PM
TheDJ claimed this task.

Should be fixed, since the SVG version of the toolbar icons was reverted with:
https://gerrit.wikimedia.org/r/#/c/168821/

The problem could be caused by the size because the svg size is much larger then the png.

This is a bug in chrome please see https://bugs.webkit.org/show_bug.cgi?id=125118 and https://code.google.com/p/chromium/issues/detail?id=260319 the problem is because there are multiple images inside one image file. if you put them into separate image files the problem goes away.

Fixed in new patch at https://gerrit.wikimedia.org/r/#/c/181786/ you have to set something in the sprite image in svg.

GOIII moved this task from Backlog to Closed on the WikiEditor board.Apr 3 2016, 9:10 AM