Page MenuHomePhabricator

Delete extra boards on ruwiki (was:Enable Flow for testing in ruwiki)
Closed, ResolvedPublic

Description

Danny created a couple of extra boards that need to be deleted:

https://ru.wikipedia.org/wiki/Https://ru.wikipedia.org/wiki/Википедия:Песочница/Flow

https://ru.wikipedia.org/wiki/Https://ru.wikipedia.org/wiki/Википедия:Форум/Новости/Flow

(old information:)

Enable Flow for pages:

in ru.wikipedia.org according to the consensus at https://ru.wikipedia.org/wiki/Википедия:Форум/Архив/Предложения/2014/08#.D0.92.D0.BA.D0.BB.D1.8E.D1.87.D0.B8.D1.82.D1.8C_Flow


Note: specific configuration change recommendations: "grants rights "Edit post", "Delete topic" and "Delete post" to all autoconfirmed users."

Details

Reference
bz70697

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 3:51 AM
bzimport set Reference to bz70697.
bzimport added a subscriber: Unknown Object (MLST).
MBH created this task.Sep 11 2014, 3:31 AM

(In reply to MaxBioHazard from comment #0)

Hi, thank you immensely for the interest in Flow. As I said to Sunpriat, I'll have to ask the product manager what the specific timeline is for the next rollouts, and sadly it might be longer than desired (possibly a few months).

Partially because there's an upcoming staff change (a back-end developer is changing jobs), and partially because we recently enabled Flow at test pages on Frwiki and Hewiki, and they're giving us a lot of great feedback, feature-requests, and bug-reports (particularly i18n bugs), so the team needs to concentrate on those.

I read a google-translation of the discussion at Ruwiki last week, and I see that there has been a lot of discussion since then. I'll try to catch up with that soon, and answer some of the questions. (Or ask you for clarifications where the google-translation is terrible :)

Hope that helps. Ping me on-wiki, or via email, or on IRC, if you have any other questions.

Elitre added a subscriber: Elitre.Jan 16 2015, 6:04 PM
Sunpriat renamed this task from Testing Flow in ruwiki to Change the rights of user groups for Flow in ruwiki.Feb 20 2015, 2:39 PM
Sunpriat updated the task description. (Show Details)
Sunpriat set Security to None.

I don't think we need to change the group permissions for Flow. First, we need to try as it is by default. Moreover consensus for change of rights was not.

MBH renamed this task from Change the rights of user groups for Flow in ruwiki to Testing Flow in ruwiki.Feb 20 2015, 2:54 PM
MBH updated the task description. (Show Details)

Sunpriat, please, don't forgery my request.

Quiddity renamed this task from Testing Flow in ruwiki to Enable Flow for testing in ruwiki.Feb 20 2015, 7:20 PM
Quiddity raised the priority of this task from Low to High.
Quiddity updated the task description. (Show Details)
Quiddity removed a subscriber: Unknown Object (MLST).

Note, the developers are currently working on the last few tweaks, so that we can enable "Edit posts" for autoconfirmed. (everywhere)

As for "Delete topic/post", those are strictly intended to just be for admins, who have the "delete [page]" right. However, all users have the "Hide topic/post" right, which is equivalent to "undo/rollback/revert".
They'll release it with that default setup, and then await feedback about specific use-cases, once it is being used/tested.

I won't guess at a final launch date, but "very soon". :)

tomasz removed a project: Shell.Feb 23 2015, 7:40 PM
Meirae added a subscriber: Meirae.Mar 22 2015, 8:38 AM

It's enabled there, so someone just needs to use https://ru.wikipedia.org/wiki/Special:EnableFlow to enable it on appropriate pages when we're ready.

DannyH closed this task as Resolved.Mar 26 2015, 9:49 PM
DannyH claimed this task.

It's done, the 2 Flow pages are now live at ruwiki.

Responding to the note:

Note: specific configuration change recommendations: "grants rights "Edit post", "Delete topic" and "Delete post" to all autoconfirmed users."

Edit post for all users was just released today.

Users can remove inappropriate topics and posts from the page with the "Hide" feature. Hidden comments are still visible in history and contributions, the same way that they are when a user reverts an edit. Users with the ability to delete pages can also delete or suppress Flow posts.

So there are now Flow pages at :

https://ru.wikipedia.org/wiki/Википедия:Форум/Новости/Flow
https://ru.wikipedia.org/wiki/Википедия:Песочница/Flow

Thanks for your patience while we worked on the edit feature! I'm looking forward to seeing what you think of Flow.

Sunpriat reopened this task as Open.Mar 31 2015, 10:50 AM
DannyH closed this task as Resolved.Apr 1 2015, 7:36 PM
DannyH moved this task from Untriaged to Resolved on the Collaboration-Team-Triage board.

Might have to wait until board deletion is implemented.

This comment was removed by Sunpriat.
DannyH added a comment.Apr 2 2015, 4:11 PM

Oh, I'm so sorry about all of this -- making pages in the wrong place, and then not realizing there was conversation on this ticket!

We'll talk today about how soon we can delete those boards. I apologize for making a mess.

DannyH renamed this task from Enable Flow for testing in ruwiki to Delete extra boards on ruwiki (was:Enable Flow for testing in ruwiki).Apr 2 2015, 4:15 PM
DannyH updated the task description. (Show Details)
DannyH added a comment.Apr 2 2015, 8:01 PM

Okay, we talked about it. We're currently finishing up some fixes to make deleting Flow boards work properly. When those are released, then I'll be able to delete these two accidental boards.

I'm sorry for the inconvenience!

I'm going to take this out of this sprint & hold onto it for the next one.

DannyH closed this task as Resolved.May 4 2015, 11:18 PM
DannyH moved this task from Ready for next sprint to Resolved on the Collaboration-Team-Triage board.