Page MenuHomePhabricator

Buttons have text of same colour when focused
Closed, ResolvedPublic

Description

guider button with incorrect rendering

Both the buttons in the main popup and in the fixed header element are displaying incorrectly.


Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=70818

Attached:

Details

Reference
bz70801

Event Timeline

bzimport raised the priority of this task from to Needs Triage.
bzimport set Reference to bz70801.
bzimport added a subscriber: Unknown Object (MLST).

That's GettingStarted, not GuidedTour. But it is indeed a regression in MediaWiki UI, due to the mediawiki.ui.anchor code.

Specificially, because the color is set unconditionally with .mw-ui-progressive:focus you get blue on blue.

I think this may be fixed by https://gerrit.wikimedia.org/r/#/c/155856/

What fixed header element are you referring to? I assume the popup is the GettingStarted modal the screenshot shows.

shahyar+wmfbugzilla wrote:

Resolved by https://gerrit.wikimedia.org/r/#/c/123804/

(Note: I don't appear to have permission to modify this bug.)

Reverted.

Shahyar, do you have permission to edit other bugs (I think it's a global setting)? If not, you should request permission from Andre Klapper.

Change 155856 had a related patch set uploaded by Jdlrobson:
Change mw-ui anchors to require mw-ui-anchor base class, and introduce mw-ui-text base class

https://gerrit.wikimedia.org/r/155856

Please someone review Shahyar's patch. It's been sitting around for far too long.

Change 155856 merged by jenkins-bot:
Change mw-ui anchors to require mw-ui-anchor base class, and introduce mw-ui-text base class

https://gerrit.wikimedia.org/r/155856