Page MenuHomePhabricator

Pressing Backspace/Delete or creating a heading causes the page to abruptly scroll up on Internet Explorer 11
Closed, ResolvedPublic1 Story Points

Description

Author: d_iarnov

Description:
win 8.1 сенсорный .вообще нереально написать нажимая backspace чтоб стереть ошибочно написанное страницу подбрасывает вверх. и на этом точка. дальше работать соответственно не возможно. мало того в плиточном браузере вообще говорится что он не поддерживается. все браузеры у меня IE

See Also: T73561: Safari scrolls one line for every character typed


Alternative steps to reproduce (in English, from T89196):

  1. Edit [[Nausea]] in VE: https://en.wikipedia.org/wiki/Nausea?veaction=edit
  2. Scroll down to the "Medications" section
  3. Click in the middle of a sentence and hit "backspace" a few times.

Each time you do this, the page jumps, and the sentence in which the cursor is located always ends up at the very bottom of the viewport.

  1. Press "delete" key a few times

Same behaviour.

  1. Now click in the middle of the very long paragraph under "Diagnostic approach". Hit "backspace" a few times.

Once again, the page jumps, but now it is worse, because the page lands with the cursor offscreen.

Details

Reference
bz71119

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:44 AM
bzimport set Reference to bz71119.
bzimport created this task.Sep 22 2014, 1:27 PM

Thanks for taking the time to report this!

Am I correct that this is about Windows 8.1 phone?
Could you provide exact steps to reproduce (step by step) in English what exactly is broken with backspace, and where exactly this happens (web address)?

Please also see https://www.mediawiki.org/wiki/How_to_report_a_bug because "doesn't work" isn't a good bug summary. :)

Marking as "Low" priority until more details are provided.

Testing VE (both mobile and desktop) on a tablet (not phone) with both
Windows 7 and 8.1, backspacing (both using software or hardware keyboards) works, but causes the page to abruptly scroll up. Just typing text doesn't cause this behavior. I'm going to assume that this was the original issue that was meant to be reported here :)

Added possibly-related bug 71561?

For me it scrolled abruptly almost to the top of the page (but not quite) and stayed there when I continued backspacing. I was testing on https://pl.wikipedia.org/wiki/Fotografia_cyfrowa (random page), for the record.

  • Bug 72646 has been marked as a duplicate of this bug. ***
Jdforrester-WMF renamed this task from VisualEditor: Pressing "Backspace" causes the page to abruptly scroll up on IE 11 to Pressing "Backspace" or creating a heading causes the page to abruptly scroll up on Internet Explorer 11.Dec 12 2014, 8:50 PM
Jdforrester-WMF set Security to None.

I'd like to get a better understanding of how to troubleshoot and extend VE and this issue has been marked as very important by a client.

I've poked at similar bugs, but I'm not sure how they relate to this one and their solutions confuse me. Is there anywhere I can look for more information on tracking it down?

Probably not. We keep all existing documentation public, in source code or on mediawiki.org.

Jdforrester-WMF lowered the priority of this task from High to Normal.Jan 15 2015, 12:51 AM
Jdforrester-WMF moved this task from External and Administrivia to Freezer on the VisualEditor board.
matmarex renamed this task from Pressing "Backspace" or creating a heading causes the page to abruptly scroll up on Internet Explorer 11 to Pressing Backspace/Delete or creating a heading causes the page to abruptly scroll up on Internet Explorer 11.Feb 11 2015, 5:01 PM
matmarex updated the task description. (Show Details)
matmarex added a subscriber: TTO.
TTO updated the task description. (Show Details)Feb 11 2015, 11:04 PM

Change 207875 had a related patch set uploaded (by MarkAHershberger):
Fix screen jumping

https://gerrit.wikimedia.org/r/207875

Change 207875 merged by jenkins-bot:
ui.ListAction: Fix screen jumping in Internet Explorer

https://gerrit.wikimedia.org/r/207875

Uziel302 reopened this task as Open.Feb 18 2017, 7:07 AM
Uziel302 added a subscriber: Uziel302.

On android, mobile view, editing any wikimedia page, using backspace or cut for deleting text, makes the screen scroll up to almost top of page. For example, I try to edit https://en.m.wikipedia.org/wiki/Ringwoodite top paragraph, backspace to delete the dot on the end scrolls me back to | class... in the infobox.

TTO closed this task as Resolved.Feb 18 2017, 7:53 AM

This task is about VisualEditor. It sounds like you are talking about the mobile source editor, so please file a new task.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptFeb 18 2017, 7:53 AM

This bug still appears on the english wikipedia.