Page MenuHomePhabricator

Run sendConfirmAndMigrateEmail.php for all unconfirmed emails on all wikis
Closed, ResolvedPublic

Description

Before sending out notifications by email to accounts that will be affected by SUL finalization, we need make sure that email addresses are confirmed to accounts. Users are initially asked to do so when an account is registered by email, but often the account does not get confirmed.

This script will send a language-localized notification by email requesting confirmation of email. The plan is the send the notification the week of 8 December and set the cookie for 14 days.


We can't unify nor notify users if we don't know their email addresses for sure. This script was written last year by pgehres to solve the problem and by now it has translations in over 40 languages.

sendConfirmAndMigrateEmail.php --userlist $APPROPRIATE_LOCAL_LIST needs to be run on all wikis for those "non-attached accounts... with e-mail" [[mw:Admin_tools_development/SUL_Audit]]; unconfirmed emails are skipped automatically (cf. bug 54760) but could also just be removed from the input list.

/**

  • Class SendConfirmAndMigrateEmail *
  • This maintenance script is used to resend confirmation emails to users with
  • unattached accounts in the hopes that we will then be able to automatically
  • attach some unattached accounts. In addition, by using an EmailableUser object
  • we are able to override the contents of the email and send them to Special:MergeAccount
  • instead of Special:ConfirmEmail and thus put them right into the workflow to attach
  • accounts by password. *
  • THIS MUST BE RUN ON THE LOCAL WIKI SO THAT THE EMAIL IS SENT IN THE CORRECT LANGUAGE */

Version: wmf-deployment
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=54760

Details

Reference
bz71241

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:53 AM
bzimport set Reference to bz71241.
Nemo_bis created this task.Sep 24 2014, 4:34 PM

Given tight SUL finalisation schedule, this certainly needs to be done within weeks rather than several months. Tentatively setting "High".

I've asked some times on #wikimedia-tech and #wikimedia-operations and the impression I got is that this amount of emails is negligible for the system, considering polonium sends about 13 millions messages per day on average according to exim stats.

Keegan added a comment.Nov 6 2014, 9:04 PM

Thanks for the ping, Nemo. I've given legoktm the green light to run the script at his earliest convenience.

08.52 < Nemo_bis> legoktm: is https://bugzilla.wikimedia.org/show_bug.cgi?id=71241 blocked on anything I can help with?
08.52 < legoktm> I just finished generating the list of users to be notified ~30 minutes ago, and am writing an email to the ops list right

now :)

Generated the lists of users to be notified, there is a file for each wiki in /home/legoktm/spam/ on terbium. Total of 1,831,168.

Email sent to ops list to make sure it's ok to send out this many emails and at what rate they should be sent at.

revi added a subscriber: revi.Dec 5 2014, 12:58 PM

Did this happen? In case that was the issue: I don't think this should be blocked on VERP. (But if it was, then it should be marked as such here.)

Elitre added a subscriber: Elitre.Jan 16 2015, 6:02 PM
This comment was removed by Keegan.
Keegan closed this task as Resolved.Jan 28 2015, 9:28 PM
Keegan reopened this task as Stalled.Jan 28 2015, 9:37 PM

HHVM upstream bug still blocking this: T78727

This script can be ran next week once the upstream fix is on the cluster.

The patch, for reference: https://github.com/facebook/hhvm/commit/fd41d2001042bf208864da0d08e3dd96a52e43f5

Legoktm changed the task status from Stalled to Open.Feb 12 2015, 7:47 PM

Emails are currently being sent out.

I split up the emails by wiki type, today emails for testwiki, wikibooks, wikinews, wikiquote, and wikisource were sent out. Will resume again tomorrow morning (PST).

Keegan moved this task from To-do to Doing on the SUL-Finalization board.Feb 13 2015, 7:29 AM
tomasz removed a project: Shell.Feb 23 2015, 7:40 PM

This has been done. @Legoktm wanted to double check before closing.

Legoktm closed this task as Resolved.Mar 5 2015, 10:07 PM
Krenair moved this task from Doing to Done on the SUL-Finalization board.Mar 8 2015, 1:36 AM
bd808 moved this task from Done to Archive on the MediaWiki-Core-Team board.Mar 9 2015, 9:14 PM
Nemo_bis added a comment.EditedApr 4 2015, 12:22 PM

Trying to calculate an approximate click-through rate... (At least for unconfirmed emails; confirmed emails are sent a bare Special:MergeAccount link without token.)

$ echo "12 13 14 15 16 17 18" | xargs -n 1 -P 3 -I '{}' wget https://dumps.wikimedia.org/other/pagecounts-ez/merged//2015/2015-02/pagecounts-2015-02-{}.bz2
$ echo "12 13 14 15 16 17 18" | xargs -n 1 -P 8 -I '{}' bzgrep -Ec 'MergeAccount/[0-9a-f]{32}' pagecounts-2015-02-{}.bz2
165
134
504
106
53
158
448

And the next week (also unsorted): 769 87 85 120 48 560. Then they go down to around 20. So it takes 2 weeks for most users to have acted on such notifications (and then those links expire anyway).

The visits to MergeAccount recorded by https://dumps.wikimedia.org/other/pagecounts-ez/merged// (which include less than 200 wikis due to aggregation and may exclude the localised versions due to their being 301 redirects) are 10152, 9867 and 20472 respectively for January, February and March. Hmmm.