Page MenuHomePhabricator

Flow: starting a new topic creates two entries in logs/feeds
Closed, DuplicatePublic3 Story Points

Description

[2015 Update: The Watchlist aspect was solved (links below), but this still needs to be fixed in RC/Contribs/Histories.]


The topic creation and mandatory first comment appear as two separate entries in Special:Watchlist. If you click _hist_, it has

  • YOU commented on "Topic Name" (Comment snippet) ...
  • YOU created the topic "Topic Name" .

it could be handled better.

Reported by Oiyarbepsy in https://en.wikipedia.org/wiki/Topic:S3i5durwbrwlq6lf

Details

Reference
bz71619

Event Timeline

bzimport raised the priority of this task from to Needs Triage.
bzimport set Reference to bz71619.
bzimport added a subscriber: Unknown Object (MLST).
Spage created this task.Oct 3 2014, 7:35 PM
DannyH added a comment.Oct 6 2014, 6:05 PM

Yeah, I was just talking to Nick about this last week. Let's talk about it at the estimation meeting.....

DannyH added a comment.Oct 6 2014, 6:09 PM

Filed a ticket in the backlog - https://trello.com/c/9Nr3J4qM

gerritadmin wrote:

Change 166407 had a related patch set uploaded by Matthias Mullie:
(bug 71619) Remove duplicate "created topic" item from watchlist

https://gerrit.wikimedia.org/r/166407

gerritadmin wrote:

Change 166407 merged by jenkins-bot:
(bug 71619) Remove duplicate "created topic" item from watchlist

https://gerrit.wikimedia.org/r/166407

gerritadmin wrote:

Change 166916 had a related patch set uploaded by EBernhardson:
Bug: Duplicate items on watchlist

https://gerrit.wikimedia.org/r/166916

gerritadmin wrote:

Change 166916 merged by Matthias Mullie:
Bug: Duplicate items on watchlist

https://gerrit.wikimedia.org/r/166916

All patches mentioned in this report were merged or abandoned - is there more work left to do here (if yes: please reset the bug report status to NEW or ASSIGNED), or can you close this ticket as RESOLVED FIXED?

Quiddity removed a subscriber: Maryana.Dec 19 2014, 1:41 AM
EBernhardson closed this task as Resolved.Feb 19 2015, 6:52 PM
EBernhardson claimed this task.

pretty sure this has been fixed, please reopen if the issue is seen again.,

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMar 31 2015, 6:29 PM
Quiddity renamed this task from Flow: starting a new topic creates two watchlist entries to Flow: starting a new topic creates two entries in logs/feeds.Mar 31 2015, 7:00 PM
Quiddity updated the task description. (Show Details)
Quiddity set Security to None.
DannyH triaged this task as High priority.Mar 31 2015, 8:39 PM
DannyH moved this task from Untriaged to Team discussion on the Collaboration-Team-Triage board.
DannyH edited a custom field.Apr 1 2015, 6:18 PM
EBernhardson removed EBernhardson as the assignee of this task.Apr 23 2015, 10:46 PM
EBernhardson removed a subscriber: EBernhardson.