Page MenuHomePhabricator

labsconsole: Empty instance list
Closed, DuplicatePublic

Description

Screenshot showing empty instance list

I am not able to see the instance listing from the https://wikitech.wikimedia.org/wiki/Special:NovaInstance. I am able to choose the filter. But I see only the project title. No instances listed. See the screenshot.


Version: unspecified
Severity: normal

Attached:

Details

Reference
bz71731

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:50 AM
bzimport added a project: Cloud-VPS.
bzimport set Reference to bz71731.
bzimport added a subscriber: Unknown Object (MLST).
santhosh created this task.Oct 7 2014, 3:50 AM
Reedy added a comment.Oct 7 2014, 3:24 PM

(In reply to Santhosh Thottingal from comment #0)

Created attachment 16687 [details]
Screenshot showing empty instance list
I am not able to see the instance listing from the
https://wikitech.wikimedia.org/wiki/Special:NovaInstance. I am able to
choose the filter. But I see only the project title. No instances listed.
See the screenshot.

It's a known session bug... If you log out, and back in again, it should fix it for you

Attached:

Indeed, turning it off and on fixes it...

I'm unsure why this is happening, though.

(In reply to Sam Reed (reedy) from comment #1)

It's a known session bug... If you log out, and back in again, it should fix
it for you

Worked when logged out and logged in. Strange. Is this issue tracked elsewhere?

scfc added a comment.Oct 7 2014, 4:25 PM

IIRC Andrew once said that the authentication tokens for MediaWiki and OpenStack time out at different times, or something like that.

Andrew added a comment.Oct 7 2014, 4:27 PM

Yeah, when running openstack queries OpenStackManager really needs to detect expired tokens and say something rather than just displaying the page as though you have no rights at all