Page MenuHomePhabricator

VisualEditor: [Regression pre-wmf3] Citation dialog inserts empty reference
Closed, ResolvedPublic

Description

Steps to reproduce:

1.Open a page with VE
2.Insert Cite>Website/News/Journal etc

Observed Result:
All citation notes are getting added as basic reference, opening them opens the basic reference dialog instead of the citation dialog.

Environment:Betalabs


Version: unspecified
Severity: major

Details

Reference
bz71825

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:56 AM
bzimport set Reference to bz71825.
Ryasmeen created this task.Oct 8 2014, 7:19 PM

Created attachment 16719
Screenshot

Attached:

This is happening because the references inserted by the citation dialog are empty, they don't have a template in them like they should.

Change 165592 had a related patch set uploaded by Catrope:
Followup b8d8a5b: pass selections, not ranges, to SurfaceFragment#clone

https://gerrit.wikimedia.org/r/165592

Change 165593 had a related patch set uploaded by Catrope:
Followup b8d8a5b: pass selections, not ranges, to SurfaceFragment#clone

https://gerrit.wikimedia.org/r/165593

Change 165592 merged by jenkins-bot:
Followup b8d8a5b: pass selections, not ranges, to SurfaceFragment#clone

https://gerrit.wikimedia.org/r/165592

Change 165593 merged by jenkins-bot:
Followup b8d8a5b: pass selections, not ranges, to SurfaceFragment#clone

https://gerrit.wikimedia.org/r/165593

(Core pull-through not yet merged but otherwise fixed.)

Verified the fix in Betalabs

Verified the fix in test2

Verified the fix in production