Page MenuHomePhabricator

Add Ukrainian name for Education Program namespace
Closed, ResolvedPublic

Description

Although the extension is fully translated on Translatewiki, the namespace still appears untranlated on Ukrainian Wikipedia. Perhaps a new entry should be added to EducationProgram.i18n.ns.php:

$namespaceNames['uk'] = array(

EP_NS => 'Освітня програма',
EP_NS_TALK => 'Обговорення освітньої програми',

);


Version: unspecified
Severity: normal

Details

Reference
bz71953

Event Timeline

bzimport raised the priority of this task from to Needs Triage.
bzimport set Reference to bz71953.
bzimport added a subscriber: Unknown Object (MLST).

Hi YurB! Thanks for your report!

Only in case you feel like trying to prepare a patch yourself:
You are welcome to use Developer access at https://www.mediawiki.org/wiki/Developer_access to submit a Git branch directly into Gerrit: https://www.mediawiki.org/wiki/Git/Tutorial
If you don't want to set up Git/Gerrit, you can also use https://tools.wmflabs.org/gerrit-patch-uploader/

gerritadmin wrote:

Change 167199 had a related patch set uploaded by AndyRussG:
Add Ukranian translantions for EP namespaces

https://gerrit.wikimedia.org/r/167199

Thanks, AndyRussG. :)

NickK triaged this task as High priority.Apr 3 2015, 1:23 PM
NickK added a subscriber: NickK.

Please resolve this ASAP: as T91204 was closed, Ukrainian Wikipedia now displays Russian translations instead of Ukrainian ones. Despite Ukrainian translations were submitted back in October 2014 and Russian translations were submitted in March 2015, this request is still not resolved.

The problem is that Russian is a default fallback language for Ukrainian Wikipedia (we wanted to remove it in T39314 and in T39329 but it was rejected), so when there is no Ukrainian translation Russian translation is displayed.

Ukrainian community is very annoyed by the fact that Ukrainian Wikipedia now displays Russian name of the namespace - for known reasons Ukrainian community does not agree with Russian translations being displayed, while English translations are considered acceptable (see https://uk.wikipedia.org/wiki/Вікіпедія:Кнайпа_(технічні_питання)#Випадаюче_меню for the community discussion).

AS added a subscriber: AS.Apr 3 2015, 1:30 PM
Elitre raised the priority of this task from High to Unbreak Now!.Apr 3 2015, 1:35 PM

Trying to raise priority.

I'm not sure whether we could get it deployed before next Monday. @greg ?

greg added a subscriber: AndyRussG.Apr 3 2015, 3:00 PM

Wow, that patch is old....

@AndyRussG: can you fix that minor comment from Siebrand and then come online to get it deployed (ping me in -operations).

Change 167199 had a related patch set uploaded (by Glaisher):
Add Ukranian translations for EP namespaces

https://gerrit.wikimedia.org/r/167199

It is old! Thanks @Glaisher, @greg, @NickK and everyone else, very sorry that I didn't see this wasn't through! 8p

Change 167199 merged by jenkins-bot:
Add Ukrainian translations for EP namespaces

https://gerrit.wikimedia.org/r/167199

Change 201993 had a related patch set uploaded (by AndyRussG):
Add Ukrainian translations for EP namespaces

https://gerrit.wikimedia.org/r/201993

Change 201994 had a related patch set uploaded (by AndyRussG):
Add Ukrainian translations for EP namespaces

https://gerrit.wikimedia.org/r/201994

Change 201993 merged by jenkins-bot:
Add Ukrainian translations for EP namespaces

https://gerrit.wikimedia.org/r/201993

Change 201994 merged by jenkins-bot:
Add Ukrainian translations for EP namespaces

https://gerrit.wikimedia.org/r/201994

Deployed this morning--thanks a ton, @Manybubbles! (Sorry I wasn't able to push it out Friday.) :)

AndyRussG closed this task as Resolved.Apr 6 2015, 3:14 PM
AndyRussG set Security to None.
Restricted Application added a subscriber: Base. · View Herald TranscriptJan 28 2016, 5:56 PM