Page MenuHomePhabricator

Warning text about missing author/source gets parsed as author/source name in Commons templates
Closed, ResolvedPublic

Description

Commons has about 56.000 images in https://commons.wikimedia.org/wiki/Category:Images_without_source . The files use the information template, but the source field isn't set. This makes the information template output the message "This file is lacking source information.

Please edit this file's description and provide a source." The files don't seem to be added to https://commons.wikimedia.org/wiki/Category:Files_with_no_machine-readable_source , the media viewer just shows the no source message.


Version: unspecified
Severity: normal

Details

Reference
bz71957

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:48 AM
bzimport added a project: CommonsMetadata.
bzimport set Reference to bz71957.
bzimport added a subscriber: Unknown Object (MLST).

I think this is the intended behavior, not a bug. The categories aim to identify files without a /machine-readable/ source. If the file has the appropriate {{information}} (or similar) template, then the source is machine-readable, regardless of whether or not it's actually present. The presence of a source and its machine-readability are different matters.

Tgr added a comment.Oct 14 2014, 11:42 AM

This is a problem with the template, as it does output machine-readable "source information", except it's not real information but a warning text. The [[c:COM:MRD]] markup should not be output when the text is autogenerated. (Compare with the permission field which does have such logic.)

Same for categorization as lacking author information.

Gilles triaged this task as Low priority.Nov 24 2014, 1:51 PM
Gilles added a subscriber: Gilles.
Tgr renamed this task from Images without source field set don't end up in the tracker category to Warning text about missing author/source gets parsed as author/source name in Commons templates.Dec 5 2014, 8:17 PM
Tgr set Security to None.
Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 6:08 PM
Restricted Application added subscribers: Steinsplitter, Matanya. · View Herald TranscriptSep 4 2015, 6:08 PM
Tgr closed this task as Resolved.Jan 16 2016, 11:50 PM
Tgr claimed this task.

The template was fixed long ago.