Page MenuHomePhabricator

'View History' button appears and disappears in a cycle when inner width is 667px in Chrome on Win8
Closed, ResolvedPublic

Description

Author: mjstevens777

Description:
When the browser's inner width is 667px, the 'View History' button oscillates between being shown and hidden. Using current version of Chrome on Windows 8
(667px is the default size of my screen on my lenovo laptop when using the split screen feature, so this may affect a large number of users)


Version: unspecified
Severity: normal

Details

Reference
bz72089

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 3:56 AM
bzimport set Reference to bz72089.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Oct 15 2014, 7:39 PM

On which page can this be seen? Cannot reproduce on en.wikipedia.org with Chrome 38 on Fedora 20 (but different operating systems might use different fonts).

mjstevens777 wrote:

I can reproduce it in Chrome on Arch Linux, but because of fonts, the critical size 668px. One pixel larger or smaller and the bug will not appear.

I did some digging in the javascript, in the $.collapsibleTabs extension.
In the expandCondition function, the width of the View History button is 83, and the width of the More button is 57. eleWidth + 1 - originalDropdownWidth = 27. The distance between the tabs is 27.45px, so it would appear as if there is enough space to expand. However, when the tab is expanded, they overlap by 0.32px.

Therefore the actual difference in expanded width was 27.78, while the calculated difference was 27. I would suggest just keeping the tabs collapsed for one extra pixel by adding one to the calculated expansion width.

Thanks for your help!

mjstevens777 wrote:

It appears on any en.wikipedia.org article

matmarex set Security to None.
matmarex removed a subscriber: Unknown Object (MLST).
matmarex claimed this task.Dec 16 2014, 4:45 PM
matmarex raised the priority of this task from Normal to High.

Change 180206 had a related patch set uploaded (by Bartosz Dziewoński):
Remove 'margin-left: -1px;' on "More" menu

https://gerrit.wikimedia.org/r/180206

Patch-For-Review

Krinkle closed this task as Resolved.Dec 16 2014, 7:06 PM
Krinkle removed a project: Patch-For-Review.

Change 180206 merged by jenkins-bot:
Remove 'margin-left: -1px;' on "More" menu

https://gerrit.wikimedia.org/r/180206