Page MenuHomePhabricator

Missing page revisions on enwiki
Closed, ResolvedPublic

Description

I noticed the top revisions for at least several pages on enwiki do not exist in the revision table, after my bot started freaking out. For example:

MariaDB [enwiki_p]> SELECT page_title, page_namespace, page_latest FROM page WHERE page_id = 43895206;
+------------------------------+----------------+-------------+

page_titlepage_namespacepage_latest

+------------------------------+----------------+-------------+

Anthony_Randolph_(economist)118626463325

+------------------------------+----------------+-------------+
1 row in set (0.00 sec)

MariaDB [enwiki_p]> SELECT * FROM revision WHERE rev_id = 626463325;
Empty set (0.00 sec)

Looking further, it seems that there are nearly 12,000 pages with this problem:

MariaDB [enwiki_p]> SELECT COUNT(*) FROM page LEFT OUTER JOIN revision ON page_latest = rev_id WHERE rev_id IS NULL;
+----------+

COUNT(*)

+----------+

11831

+----------+
1 row in set (5 min 52.01 sec)

This is not a replication lag issue; the lag is zero.

I am not clear if this is related to bug 71084 or bug 70711.


Version: unspecified
Severity: major
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=71176
https://bugzilla.wikimedia.org/show_bug.cgi?id=71084
https://bugzilla.wikimedia.org/show_bug.cgi?id=70711
https://bugzilla.wikimedia.org/show_bug.cgi?id=72413

Details

Reference
bz72226

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:48 AM
bzimport added a project: Toolforge.
bzimport set Reference to bz72226.
Earwig created this task.Oct 19 2014, 5:39 AM

Sync in progress. Cause is not yet confirmed, with https://mariadb.atlassian.net/browse/MDEV-6551 a possibility.

Very interested to hear if anyone observes this with recent (<1week) data.

coren moved this task from Triage to In Progress on the Toolforge board.Nov 25 2014, 4:07 PM
yuvipanda changed the task status from Open to Stalled.Mar 9 2015, 3:14 PM
yuvipanda added a subscriber: yuvipanda.

Is this still happening? @Earwig?

Krenair added a subscriber: Krenair.Mar 9 2015, 4:50 PM
Earwig closed this task as Resolved.Mar 9 2015, 11:50 PM

Interesting. It seems like the problem has been resolved, although 16 pages still result from the above query. However, that looks like accurate replication of a corrupted database rather than the other way around, so I'm deferring to T92046.

Restricted Application added a project: Cloud-Services. · View Herald TranscriptJun 7 2017, 6:57 PM