Page MenuHomePhabricator

extract(?) ignores images in galleries when providing image previews
Closed, InvalidPublic

Description

example https://en.wikipedia.org/wiki/Pioneer_Race_Course

when viewing this page as a hovercard, in a search result, or via nearby, the images in the gallery are not provided as previews even though they all would be valid previews, if the images in the gallery are removed from the gallery they show in these cases.

Details

Reference
bz72276

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:51 AM
bzimport added a project: PageImages.
bzimport set Reference to bz72276.
bzimport added a subscriber: Unknown Object (MLST).

It can, but this functionality is enabled only on Commons ATM because on Wikipedia it seems a lot of images in galleries in WP artcles are not representative enough of article subject: if a pic is relevant enough, it's usually placed standalone in the lead, not at a gallery closer to article end. The article you mentioned looks like it should really use the image in lead, and it's not being used because its scores were negatively impacted by its size - I'm gonna fix this in a bit.

I would really love to see some analysis of ratio of pages where results could be improved by gallery images vs. pages where they will get less useful/more misleading.

(In reply to Max Semenik from comment #1)

The article you mentioned looks like it should really use the image in
lead, and it's not being used because its scores were negatively impacted by
its size - I'm gonna fix this in a bit.

Thanks, that saves me filing a separate bug. (I'd pinged Prateek at https://www.mediawiki.org/wiki/Topic:S42evpqwzrzfeak9 and was hoping he'd recognize the issue.)

(In reply to Quiddity from comment #2)

Thanks, that saves me filing a separate bug. (I'd pinged Prateek at
https://www.mediawiki.org/wiki/Topic:S42evpqwzrzfeak9 and was hoping he'd
recognize the issue.)

https://gerrit.wikimedia.org/r/167716

Prtksxna triaged this task as Normal priority.Dec 3 2014, 11:32 AM
Prtksxna updated the task description. (Show Details)
Prtksxna set Security to None.

@MaxSem, since the patch has been merged the image that shows up now is the one from the gallery. Is that the intended behavior?


Go to https://en.wikipedia.org/wiki/Mission_District,_San_Francisco and hover on Pioneer Race Course.

Nemo_bis lowered the priority of this task from Normal to Low.Apr 7 2015, 3:55 PM
Nemo_bis added a subscriber: Nemo_bis.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 14 2015, 11:11 PM
Prtksxna removed a subscriber: Prtksxna.Jul 5 2016, 11:29 AM
Jdlrobson closed this task as Invalid.Apr 27 2017, 7:43 PM
Jdlrobson added a subscriber: Jdlrobson.

No longer valid as page image can only come from the lead section.