Page MenuHomePhabricator

Special:Userprofile does not currently work on desktop.
Closed, ResolvedPublic

Description

If you go to https://en.m.wikipedia.org/wiki/Special:UserProfile/Sue_Gardner and click the "Desktop" link at the bottom, everything breaks and the children cry.


Version: unspecified
Severity: major

Details

Reference
bz72323
Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterEnable user profile on desktop.

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:54 AM
bzimport set Reference to bz72323.
bzimport added a subscriber: Unknown Object (MLST).

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/NZPGIO91

This is by design. As the page says "This page is not available on desktop. Please click the mobile view link at the bottom of the page."

We cannot guarantee support for the desktop equivalent whilst we don't have any frontend standards across the site. This is why Special:Nearby breaks /all/ the time.

To enable it on desktop is trivial but we cannot guarantee support for it.

If this is important you'll have to convince Maryana that we need to invest time in supporting it and decide whether we need to adapt the styling on desktop and link to it from anywhere.

Created attachment 16831
Special:Userprofile on desktop

Attached:

Added Maryana to CC list. What we want to do?

Jdlrobson renamed this task from "Desktop" link doesn't work on User pages on mobile to Special:Userprofile does not currently work on desktop..Dec 5 2014, 7:38 PM
Jdlrobson set Security to None.

It's by design. If someone wants to enable it and put some time into making sure it renders nicely on the Vector skin be my guest but it's not clear what it should look like on the desktop skin.

Change 182337 had a related patch set uploaded (by Jdlrobson):
Enable user profile on desktop.

https://gerrit.wikimedia.org/r/182337

Patch-For-Review

Change 182337 merged by jenkins-bot:
Enable user profile on desktop.

https://gerrit.wikimedia.org/r/182337

Jdlrobson closed this task as Resolved.Jan 6 2015, 4:02 PM
Jdlrobson claimed this task.