Page MenuHomePhabricator

Reference lists appearing in extracts for some articles
Closed, ResolvedPublic

Description

[[Jolie_Holland]] (https://en.wikipedia.org/w/api.php?action=query&titles=Jolie_Holland&prop=extracts&exintro=1) has a reference list in the extract.

It includes ^ links that don't work, and the rest of the extract has the [1] indicators removed as well.

[[Lat_Leyl]] found via Special:Random (https://en.wikipedia.org/w/api.php?action=query&titles=Lat_Leyl&prop=extracts&exintro=1) has references in the lead section, but no reference list in the extract.

MB bug report: http://tickets.musicbrainz.org/browse/MBS-7766


Version: unspecified
Severity: normal

Details

Reference
bz72629

Related Objects

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:57 AM
bzimport added a project: TextExtracts.
bzimport set Reference to bz72629.
bzimport added a subscriber: Unknown Object (MLST).
Legoktm created this task.Oct 28 2014, 4:55 PM

happening for both plaintext and html output.

copying over from merged task:
In the hovercard of the german article de:Marco Polo (Webserie) after the first two sentences/points, the first reference is shown on the hovercard.
Popups api call: https://de.wikipedia.org/w/api.php?action=query&format=json&prop=extracts|pageimages|revisions|info&redirects=true&exintro=true&exsentences=2&explaintext=true&piprop=thumbnail&pithumbsize=300&rvprop=timestamp&inprop=watched&indexpageids=true&titles=Marco+Polo+%28Webserie%29

Caused by T73023 - phab shows an error when I try to add it as a blocker.

[offtopic]

Caused by T73023 - phab shows an error when I try to add it as a blocker.

As with any software error, providing an actual error message would be helpful (preferably via email as that's off-topic for this task).

Change 275361 had a related patch set uploaded (by Putnik):
Add ol.references to ignored elements

https://gerrit.wikimedia.org/r/275361

putnik added a subscriber: putnik.Mar 28 2016, 10:54 PM

I added a very simple patch that removes the references list in the same manner as ref tags. It is not necessary to solve the T73023 first.

Change 275361 merged by jenkins-bot:
Add ol.references to ignored elements

https://gerrit.wikimedia.org/r/275361

Jdlrobson closed this task as Resolved.Jul 7 2016, 5:13 PM
Jdlrobson claimed this task.
Jdlrobson added a subscriber: Jdlrobson.

This appears to have been fixed by https://gerrit.wikimedia.org/r/275361