We regressed in usability of Jenkins output for MediaWiki core change sets.
For mediawiki-core commits there is no longer a phpunit job. It's not clear to users what the "vendor-integration" job is for. It used to be run alongside plain mediawiki phpunit, but it's now the only one. "vendor" is no longer a special thing and just normal operation for MediaWiki core now. So it doesn't need to be pointed out in the job name.
There is some re-use of the job going on I think, in that case it makes sense to not name it in a way specific to mediawiki-core. In that case I'd recommend naming it "mediawiki-phpunit" or simply create a second instance of the same job and name that one "mediawiki-core-phpunit" and use the vendor only for non-core.