Page MenuHomePhabricator

Login link redirect to default login (with MobileFrontend)
Closed, InvalidPublic

Description

Author: tim.schenk

Description:
The link supplied by the mobile page redirects to :
http://wiki.firstconsulting.nl/Speciaal:Aanmelden <-- dutch

This is the default login page and not the special GoogleLogin page.
In my LocalSetting.php I have:
$wgGLReplaceMWLogin = true;

Is this a GoogleLogin bug, or a MobileFrontend bug?


Version: master
Severity: normal

Details

Reference
bz72909

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 4:00 AM
bzimport set Reference to bz72909.
bzimport created this task.Nov 3 2014, 4:21 PM

Actually it depends on MobileFrontend in a special way :) Both Extensions, MobileFrontend and GoogleLogin, will rewrite the handler for the Login class. GoogleLogin will do this only, if $wgGLReplaceMWLogin is set to true to prevent the vanilla LoginForm to appear.

MobileFrontend was created in an early version of MediaWiki and had to replace the LoginForm, too, to fit the needs of a mobile device (it will do this every time, the user is in mobile mode).

Now, the problem is, that the login page can be only one class and it wins the extension that has overwritten the key last.

So, in fact, the Extension which was loaded last will provide the login screen. That means for you, as a quick fix, that you can place the "require_once" line of GoogleLogin somewhere _after_ the MobileFrontend "require_once" line. This should solve the problem for now.

The best solution is, that MobileFrontend doesn't need to overwrite the login page anymore. Actually, the developer team is working on this and implemented such a feature in the alpha mode of MobileFrontend (I8f89bdaf3dc7fde104f199554b18486c30580910). It will take some time to solve this problem, but it isn't a real bug of GoogleLogin. I will create a tracking but for this in MobileFrontend :)

(I will set the status of this bug to assigned and take it anyway, but the work has to be done in MobileFrontend :))

P.S.: Thanks for the very detailed bug report! :)

tim.schenk wrote:

Florian, thanks for your help.
Changing the order in which the extensions load solves my problem.

Thanks again for the fast reply!

Thanks for confirm this :)

Added the info to the Extension page: [[Extension:GoogleLogin#MobileFrontend_.3C-.3E_GoogleLogin_conflict_.28only_with_.24wgGLReplaceMWLogin_.3D_true.21.29]]

Florian renamed this task from Login link redirect to default login (not GoogleLogin) to Login link redirect to default login (with MobileFrontend).Nov 28 2014, 11:18 PM
Florian set Security to None.
Jdlrobson closed this task as Invalid.Dec 10 2014, 12:16 AM
Jdlrobson added a subscriber: Jdlrobson.

Looks like Florian's advice fixed it? :)

@Jdlrobson: in general: yes :) But i thought, that we can let this task open as a "Blocks" for T74910?