Page MenuHomePhabricator

[Regression] Scroll into view of section on section edit link click has stopped working
Closed, ResolvedPublic

Description

In bug 65928 we got VE to scroll into view the section you clicked edit on. This is no longer working, unless you launch via URL, in which case it works just fine.


Version: unspecified
Severity: normal

Details

Reference
bz72919

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 4:00 AM
bzimport set Reference to bz72919.

I'm seeing the following behavior on Chrome 38, Windows 7:

Go to https://en.wikipedia.org/wiki/OLED , scroll down to any section header and click on [edit beta] to edit that section. Visual Editor will start, but the "Further Reading" section (much further down in the article) will be visible, not the section intended.

If you now switch to another tab in the browser and then switch back to the Visual Editor tab, the correct section will be visible.

Even the URL link https://en.wikipedia.org/w/index.php?title=OLED&veaction=edit&vesection=1 will wrongly jump to the "Further Reading" section (unless you switch tabs first).

Other long articles seem to exhibit the same behavior.

The VE version on mediawiki shows slightly different behavior, for instance on https://www.mediawiki.org/w/index.php?title=Markup_spec&veaction=edit&vesection=3

Visual Editor will wrongly start at the top of the article with cursor blinking before the first word, until you switch tabs, then it shows the correct section.

This is in Chrome 38, Windows 7. Firefox 33.0.2 works correctly.

Jdforrester-WMF renamed this task from VisualEditor: [Regression] Scroll into view of section on section edit link click has stopped working to [Regression] Scroll into view of section on section edit link click has stopped working.Nov 23 2014, 11:10 PM
Jdforrester-WMF added a project: VisualEditor.
Jdforrester-WMF set Security to None.
Krenair added a subscriber: Krenair.Jan 9 2015, 1:56 AM

I just checked this on a few different enwiki articles and cannot reproduce it. @Jdforrester-WMF, @AxelBoldt: can you confirm this is resolved? Thanks.

Both my issues on en.wiki and on mediawiki.org are resolved (Chrome 39).

Jdforrester-WMF closed this task as Resolved.Jan 10 2015, 3:17 AM
Jdforrester-WMF moved this task from External and Administrivia to Q4 on the VisualEditor board.