Page MenuHomePhabricator

Incorrect rendering of diff summaries containing lots of whitespace in Safari
Closed, ResolvedPublic

Description

Author: bugzillaforng39

Description:
See [https://en.wikipedia.org/w/index.php?title=Wikipedia:In_the_news/Candidates&diff=prev&oldid=632380777 this diff]. Also see [[Commons:File:Diff problem.png]] for another related problem.


Version: 1.25-git
Severity: minor

Details

Reference
bz72936

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 3:44 AM
bzimport set Reference to bz72936.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Nov 4 2014, 5:36 AM

(In reply to Nick Gibson from comment #0)

See
[https://en.wikipedia.org/w/index.php?title=Wikipedia:In_the_news/
Candidates&diff=prev&oldid=632380777 this diff].

Please explain what to "see" there. For general reference, https://www.mediawiki.org/wiki/How_to_report_a_bug

bugzillaforng39 wrote:

(In reply to Andre Klapper from comment #1)

(In reply to Nick Gibson from comment #0)

See
[https://en.wikipedia.org/w/index.php?title=Wikipedia:In_the_news/
Candidates&diff=prev&oldid=632380777 this diff].

Please explain what to "see" there. For general reference,
https://www.mediawiki.org/wiki/How_to_report_a_bug

The problem is that some of the edited summary is outside the bracket

Created attachment 17032
Screenshot with Firefox 33

Please provide a screenshot of the problem that you see, plus browser information.

Attached:

bugzillaforng39 wrote:

Screenshot with Mac (OSX 10.9.5)

This is a screenshot of the problem. I use OSX 10.9.5 (Safari 7.1)

Attached:

Looking at the HTML source, there are many whitespaces:

| updated       = yes

Looks like Firefox ignores them (they are no  ) while Safari does not.

Aklapper closed this task as Resolved.Sat, Aug 10, 9:28 PM
Aklapper added a subscriber: Aklapper.

Cannot reproduce in Chromium or Firefox nowadays, hence resolving this task. If this still happens, please mention your Safari version.