Page MenuHomePhabricator

page title header moved down on Commons
Closed, InvalidPublic

Description

Commons screenshot. For an en.WP comparison, see http://1drv.ms/1E5rpSp.

Since yesterday, the page title h1 and its hr have moved downwards, leading to a lot of empty space between them and the "View | Edit | Edit source | View history" tabs. See screenshots.


Version: unspecified
Severity: normal

Attached:

Details

Reference
bz73016

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:49 AM
bzimport added a project: Vector.
bzimport set Reference to bz73016.
bzimport added a subscriber: Unknown Object (MLST).
FDMS created this task.Nov 5 2014, 2:06 PM

Created attachment 17036
Firefox 33

Cannot reproduce here with Firefox 33.
What's those custom tab names about? :)

Attached:

So wait, is there something broken in our code (I definitely did not intend the indicators change to push the title down), or was the issue caused by some custom on-wiki CSS?

FDMS added a comment.Nov 5 2014, 9:27 PM

From the IRC conversation: The move only happened on 1.25wmf6 wikis (tested on Commons, Meta; didn't happen on en.WP or de.WP), and your change I linked to is "responsible" for it. Quote zhuyifei1999: "FDMS4: there's "padding-top: 0.5em;" on "div#content h1" on commons, but enwiki used "padding: 0;" on ".mw-body h1" in https://bits.wikimedia.org/en.wikipedia.org/load.php?debug=true&lang=en&modules=skins.vector.styles&only=styles&skin=vector&*".

I thought your indicators require the extra space. As having read your comment I am no longer sure this is true, reopening.

Correction and expansion to my previous IRC comment:
In a css block (in previously unknown source) there is:

div#content h1,
div#content h2,
div#content h3,
div#content h4,
div#content h5,
div#content h6 {

line-height: inherit;
 margin: 0;
 padding-top: 0.5em;
 padding-bottom: 0.17em;

}

which sets "div#content h1" to have "padding-top: 0.5em" and "padding-bottom: 0.17em"

Another more specific css block in another unknown source (which I have not dug further), there is:

div#content #firstHeading {
font-size: 1.6em;
line-height: 1.2em;
margin-bottom: 0.1em;
padding-bottom: 0;
}

which resets "padding-bottom: 0"

Previously in module "skins.vector.styles" there was another specific css block:

.mw-body h1,
.mw-body h2,
.mw-body #firstHeading {

	  font-family: "Linux Libertine", Georgia, Times, serif;
	  line-height: 1.3;
	  margin-bottom: 0.25em;
	  padding: 0;

}

to reset all paddings to 0.
However, ".mw-body #firstHeading" was removed and ".mw-body h1" is not as specific as "div#content h1", so it's overridden by the first block to have a final "padding-top: 0.5em", which is shown as the blank space on the top of the title.

But further digging I just done shows that the first block comes from ext.gadget.typographyrefreshoverride (In this case for FDMS, it's his glocal css). So for anyone who doesn't use this override, this bug just doesn't show.
Thus there're two ways to fix this bug:

  1. partly revert the git commit.
  2. fix all the typographyrefreshoverride gadgets and user css.
FDMS added a comment.Nov 6 2014, 3:51 PM

Created attachment 17060
Firefox 31 (logged-out)

Also reproducible (by me and marktraceur) while logged-out (and therefore without TypoRefreshOverride) …

Attached:

(In reply to Stöger Florian D. M. from comment #6)

Created attachment 17060 [details]
Firefox 31 (logged-out)
Also reproducible (by me and marktraceur) while logged-out (and therefore
without TypoRefreshOverride) …

Confirmed from me as well for logged-out. Unconfirmed for logged-on without TypoRefreshOverride. Looks like there's something weird going on (I'll look into it tomorrow if necessary).

Attached:

(In reply to Stöger Florian D. M. from comment #6)

Created attachment 17060 [details]
Firefox 31 (logged-out)
Also reproducible (by me and marktraceur) while logged-out (and therefore
without TypoRefreshOverride) …

This is caused by

 	#localNotice {
		margin-bottom: 0.9em;

}

under module "mediawiki.skinning.interface"

[[:c:MediaWiki:Anonnotice]] has '<p style="display:none"></p>' which makes mediawiki and browser *think* there is a anonnotice above when there is none, leaving an empty space that is used to separate sitenotice with the page title.

Attached:

matmarex closed this task as Invalid.Apr 7 2015, 6:18 PM
matmarex claimed this task.

Per comments above this is not an issue with Vector's source code, but rather local gadgets and messages.

FDMS added a comment.Apr 7 2015, 8:07 PM

Indeed, appears to be fixed now – http://enwp.org/c:Special:Diff/155289645