Page MenuHomePhabricator

Flow: Special:Contributions missing recent Flow content
Closed, ResolvedPublic

Details

Reference
bz73153

Event Timeline

bzimport raised the priority of this task from to High.
bzimport set Reference to bz73153.
Quiddity created this task.Nov 7 2014, 7:48 PM

2014-11-07 19:48:50 mw1186 mediawikiwiki: [cc8e42f1] /wiki/Special:Contributions/Skalman Exception from line
61 of /srv/mediawiki/php-1.25wmf7/extensions/Flow/includes/Model/UserTuple.php: User has both id and ip
#0 /srv/mediawiki/php-1.25wmf7/extensions/Flow/includes/Model/UserTuple.php(90): Flow\Model\UserTuple->__constr
uct('mediawikiwiki', '34721', 'Skalman')
#1 /srv/mediawiki/php-1.25wmf7/extensions/Flow/includes/Model/AbstractRevision.php(141): Flow\Model\UserTuple::
newFromArray(Array, 'rev_user_')
#2 /srv/mediawiki/php-1.25wmf7/extensions/Flow/includes/Model/PostRevision.php(153): Flow\Model\AbstractRevisio
n::fromStorageRow(Array, NULL)
#3 [internal function]: Flow\Model\PostRevision::fromStorageRow(Array, NULL)
#4 /srv/mediawiki/php-1.25wmf7/extensions/Flow/includes/Data/Mapper/CachingObjectMapper.php(89): call_user_func
(Array, Array, NULL)
#5 /srv/mediawiki/php-1.25wmf7/extensions/Flow/includes/Data/ObjectLocator.php(295): Flow\Data\Mapper\CachingOb
jectMapper->fromStorageRow(Array)
#6 /srv/mediawiki/php-1.25wmf7/extensions/Flow/includes/Data/ObjectManager.php(298): Flow\Data\ObjectLocator->l
oad(Array)
#7 /srv/mediawiki/php-1.25wmf7/extensions/Flow/includes/Data/ObjectLocator.php(96): Flow\Data\ObjectManager->lo
ad(Array)
#8 [internal function]: Flow\Data\ObjectLocator->findMulti(Array, Array)
#9 /srv/mediawiki/php-1.25wmf7/extensions/Flow/includes/Data/ManagerGroup.php(129): call_user_func_array(Array,
Array)
#10 /srv/mediawiki/php-1.25wmf7/extensions/Flow/includes/Data/ManagerGroup.php(145): Flow\Data\ManagerGroup->ca
ll('findMulti', Array)
#11 /srv/mediawiki/php-1.25wmf7/extensions/Flow/includes/Formatter/AbstractQuery.php(125): Flow\Data\ManagerGro
up->findMulti('PostRevision', Array, Array)
#12 /srv/mediawiki/php-1.25wmf7/extensions/Flow/includes/Formatter/ContributionsQuery.php(70): Flow\Formatter\A
bstractQuery->loadMetadataBatch(Array)
#13 /srv/mediawiki/php-1.25wmf7/extensions/Flow/Hooks.php(630): Flow\Formatter\ContributionsQuery->getResults(O
bject(ContribsPager), '', 51, false)
#14 [internal function]: FlowHooks::onContributionsQuery(Array, Object(ContribsPager), '', 51, false)
#15 /srv/mediawiki/php-1.25wmf7/includes/Hooks.php(206): call_user_func_array('FlowHooks::onCo...', Array)
#16 /srv/mediawiki/php-1.25wmf7/includes/GlobalFunctions.php(3940): Hooks::run('ContribsPager::...', Array, NUL
L)
#17 /srv/mediawiki/php-1.25wmf7/includes/specials/SpecialContributions.php(756): wfRunHooks('ContribsPager::...
', Array)
#18 /srv/mediawiki/php-1.25wmf7/includes/pager/IndexPager.php(222): ContribsPager->reallyDoQuery('', 51, false)
#19 /srv/mediawiki/php-1.25wmf7/includes/pager/IndexPager.php(556): IndexPager->doQuery()
#20 /srv/mediawiki/php-1.25wmf7/includes/specials/SpecialContributions.php(197): IndexPager->getNumRows()
#21 /srv/mediawiki/php-1.25wmf7/includes/specialpage/SpecialPage.php(363): SpecialContributions->execute('Skalm
an')
#22 /srv/mediawiki/php-1.25wmf7/includes/specialpage/SpecialPageFactory.php(585): SpecialPage->run('Skalman')
#23 /srv/mediawiki/php-1.25wmf7/includes/MediaWiki.php(275): SpecialPageFactory::executePath(Object(Title), Obj
ect(RequestContext))
#24 /srv/mediawiki/php-1.25wmf7/includes/MediaWiki.php(584): MediaWiki->performRequest()
#25 /srv/mediawiki/php-1.25wmf7/includes/MediaWiki.php(435): MediaWiki->main()
#26 /srv/mediawiki/php-1.25wmf7/index.php(46): MediaWiki->run()
#27 /srv/mediawiki/w/index.php(3): require('/srv/mediawiki/...')
#28 {main}

  • This bug has been marked as a duplicate of bug 71858 ***

The above exceptions and related log messages were in the log at right point in time, but is a separate problem that also manifests as missing contributions entries.

Change 172429 had a related patch set uploaded by Matthias Mullie:
Logged-in users should save null values to rev_user_id

https://gerrit.wikimedia.org/r/172429

Change 172439 had a related patch set uploaded by EBernhardson:
Logged-in users should save null values to rev_user_id

https://gerrit.wikimedia.org/r/172439

Change 172429 merged by jenkins-bot:
Logged-in users should save null values to rev_user_id

https://gerrit.wikimedia.org/r/172429

Change 172439 merged by jenkins-bot:
Logged-in users should save null values to rev_user_ip

https://gerrit.wikimedia.org/r/172439

I'm re-opening just so we remember to write the script that can fix mediawiki.org, test.wikipedia.org, and test2.wikipedia.org (Matthias pointed this out on IRC).

Change 171466 had a related patch set uploaded by EBernhardson:
Bug: prod db contains rows with both *_user_id and *_user_ip set

https://gerrit.wikimedia.org/r/171466

Change 171466 merged by jenkins-bot:
Bug: prod db contains rows with both *_user_id and *_user_ip set

https://gerrit.wikimedia.org/r/171466

Has the script been run yet?

In T75153#800158, @Mattflaschen wrote:

Has the script been run yet?

Currently in product review (I'm not sure what that implies, vis-a-vis running the script) - https://trello.com/c/PYLBJpQO/730-write-and-deploy-a-script-to-fix-the-missing-contributions-from-bug-73153

In T75153#800158, @Mattflaschen wrote:

Has the script been run yet?

Per Erik on IRC, no. It is not in any of the release branches yet, though it will be in 1.25wmf11 tomorrow.

EBernhardson closed this task as Resolved.Dec 5 2014, 5:53 PM

Maintenance script run on terbium, linked contributions in ticket now show up.

Quiddity removed a subscriber: Maryana.Dec 19 2014, 1:36 AM