Page MenuHomePhabricator

Remove Anexo namespace from Portuguese Wikipedia
Closed, ResolvedPublic

Description

Please remove the namespaces "Anexo" (102) and "Anexo Discussão" (103) from Portuguese Wikipedia.

Consensus: w:pt:Wikipédia:Esplanada/propostas/Eliminação do domínio Anexo (26abr2014).

A bot has already moved almost all pages to main namespace, and the community moved the remaining pages manually. Now, both namespaces contain only the redirects (which should still work after the removal of the namespaces).

See also: T13108: Create namespaces on pt.wikipedia

Details

Reference
bz73164

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 3:58 AM
bzimport set Reference to bz73164.
Danilo created this task.Nov 8 2014, 2:10 AM

Please complete the task now, then raise the priority from low to normal.

If we would apply the change now, you wouldn't be able to manipulate them easily after, and we would have to run a maintenance script.

gerritadmin wrote:

Change 172012 had a related patch set uploaded by Dereckson:
Remove Anexo namespace on pt.wikipedia

https://gerrit.wikimedia.org/r/172012

Danilo added a comment.Nov 8 2014, 3:41 AM

The bot won't move the other pages, the bot have moved 14000+ pages, and it left 30 pages to move manually. The remove of the namespace will not affect our job (we will be able to access the pages by [Special:PrefixIndex/Anexo:]).

The issue is page names don't start by Anexo:, but start by their respective names, excluding the namespace prefix.

Move them by hand, then notify us it has been done.

If you look on the two following namespaces, they are FAR than empty. Talk pages still present, a lot of redirections, still the page content you hinted about.

Most of them seems to be redirects, which should be kept working (i.e. not be deleted), per
https://meta.wikimedia.org/wiki/Don%27t_delete_redirects

Won't this require the maintenance script to be executed anyway?

In the initial request, the redirects would never work and disappear.

When we're in the namespace Foo, the page Bar is identified by the URL "Foo:Bar" but has "Bar" as title, not "Foo:Bar".

Helder would like we keep the redirects, this is a good idea, especially to respect W3C recommandation Hypertext Style: Cool URIs don't change.

To do that, we have two solutions.

I. To run a maintenance script to move (ns 102) Quux to (ns 0) Annexo:Quux.

II. - To socially enforce or technically with AbuseFilter the rule "don't create any new page in Annexo: namespace"

  • To let the namespace technically there to allows these redirects to operate and regroup them.

I don't see any argument in the favour to the first solution, as the namespace is still useful to regroup the redirections and doesn't provide real benefits.

(In reply to Dereckson from comment #7)

II. - To socially enforce or technically with AbuseFilter the rule "don't
create any new page in Annexo: namespace"

This is already done:
https://pt.wikipedia.org/wiki/Special:AbuseFilter/129

The "Anexo" namespace should still be removed so that it doesn't appear in places like

A page such as
https://pt.wikipedia.org/wiki/Anexo:Biografias
is currently in the namespace 102, and contains a cross-namespace redirect
#REDIRECIONAMENTO [[Lista de listas de biografias por ordem alfabética]]
so that a user accessing the URL gets to the page
https://pt.wikipedia.org/wiki/Lista_de_listas_de_biografias_por_ordem_alfab%C3%A9tica

After the requested changes, "Anexo:Biografias" should just be a page in the main namespace redirecting to another page in the same namespace (which just happen to have as prefix the string which used to be the name of a namespace). This is why we need option I.

I don't like that.

Are you sure there is a real consensus to flood the main namespace with 30K redirections?

Yes, that has been discussed and the consensus is to keep all redirections.

Change 172012 had a related patch set uploaded (by Reedy):
Remove Anexo namespace on pt.wikipedia

https://gerrit.wikimedia.org/r/172012

Patch-For-Review

mysql:wikiadmin@db1024 [ptwiki]> select count(*) from page where page_namespace in (102, 103) and not page_is_redirect;
+----------+
| count(*) |
+----------+
|       76 |
+----------+
1 row in set (0.00 sec)
tomasz removed a project: Shell.Feb 23 2015, 7:46 PM
He7d3r updated the task description. (Show Details)Feb 27 2015, 6:45 PM
He7d3r updated the task description. (Show Details)

Change 172012 merged by jenkins-bot:
Remove Anexo namespace on pt.wikipedia

https://gerrit.wikimedia.org/r/172012

demon closed this task as Resolved.Mar 2 2015, 7:49 PM
demon added a subscriber: demon.
demon added a comment.Mar 3 2015, 3:09 PM

I didn't think we needed to execute namespaceDupes because the pages had been moved already.

He7d3r added a comment.EditedMar 3 2015, 3:15 PM
In T75164#1081981, @Chad wrote:

I didn't think we needed to execute namespaceDupes because the pages had been moved already.

A page such as
https://pt.wikipedia.org/wiki/Anexo:Biografias
is currently in the namespace 102, and contains a cross-namespace redirect
#REDIRECIONAMENTO [[Lista de listas de biografias por ordem alfabética]]
so that a user accessing the URL gets to the page
https://pt.wikipedia.org/wiki/Lista_de_listas_de_biografias_por_ordem_alfab%C3%A9tica
After the requested changes, "Anexo:Biografias" should just be a page in the main namespace redirecting to another page in the same namespace (which just happen to have as prefix the string which used to be the name of a namespace). This is why we need option I.

The page
https://pt.wikipedia.org/wiki/Anexo:Biografias
doesn't redirect to
https://pt.wikipedia.org/wiki/Lista_de_listas_de_biografias_por_ordem_alfab%C3%A9tica
anymore, so it seems to be required.

demon added a comment.Mar 3 2015, 3:27 PM
demon@terbium ~$ mwscript namespaceDupes.php --wiki=ptwiki --fix
0 pages to fix, 0 were resolvable.

Looks good!
He7d3r added a comment.Mar 3 2015, 3:45 PM
In T75164#1082029, @Chad wrote:
demon@terbium ~$ mwscript namespaceDupes.php --wiki=ptwiki --fix
0 pages to fix, 0 were resolvable.
Looks good!

It doesn't, see the example at T91401: namespaceDupes not handling deleted namespace redirects as desired

Krinkle added a subscriber: Krinkle.EditedMar 4 2015, 12:52 AM

Why was #MediaWiki-Maintenance-scripts removed?

Because that project is for bugs or feature requests with the scripts themselves, as part of the MediaWiki software. Not for requests to Wikimedia to use those scripts on wikis. We have Wikimedia-Site-requests for that :-)